can't update virus database

When I click on up-date now, I get a message to check internet connection. At internet connection all settings appear to be correct.
What should I do?

What version are you using? Make sure you are using the latest version. Get it from COMODO Internet Security 3.13.126709.581 Released.

When using a version older than 3.10 you cannot import your old configuration. You will have to start from scratch again,

I’m a brand new user and novice at all things software. I’ve loaded version 3.8.65951.477.
It appears that this version is even older than 3.10 or 3.13, correct? And I too am getting error message 113: “Failed to update virus signature database. Check your internet connection.”
Is that due to my using an older version?
All was working well for a few days after I installed, but this inability to update and error message has now been displaying since 1/21.
I’m reluctant to download version 3.13 due to the other issues users have been describing in recent threads. Can I still get version 3.10?
Am I even understanding the problem correctly?

Yes, you will not be able to update version 3.8. You actually won’t be able to update anything older than 3.13 because they’ve made changes to the database format.

Sorry to be the bringer of the bad news but you will have to do a clean install of 3.13 because of changes in the AV. You cannot export your configuration from 3.8 to 3.13 either due to changes.

Get the latest version from COMODO Internet Security 3.13.126709.581 Released . The download page still provides the before last version.

As strange as it may seem, the actual download page is in fact serving the correct version. The version you download is even labeled CIS_Setup_3.13.125662.579_XP_Vista_x32.exe, (assuming you’re downloading the 32 bit version) but installing this and checking the about page confirms you instead have the current 3.13.126709.581 installed. What sort of sense this makes is beyond me, but I guess the good news is that people can download from the main page and get the right release.

Now you mention it. Umesh mentioned somewhere they had redirected their servers for this. It comes back to me now.

I don’t think it’s a simple server redirect due to the file naming oddity. With a server redirect, I would expect that you would click on the old link, but the file you receive is the newer file.

However, when you click the link, the file you get is the same name as the link. But when you install it, the version installed isn’t the version in the file name.

In other words, the file is named 3.13.125662.579, but you are actually installing 3.13.126709.581.

This is totally hopeless. I have updated to lated version and it still does not work. I am losing faith in Comodo.

There are two solutions that do this:

Both of them will get the latest full AV database. After the reboot you will have to get the latest incremental updates; usually that is only several hundreds of kBytes.

I have the same problem here: I’m using CIS version 587 and I’ve been unable to update the AV file through CIS since Sunday, February 14. I get the message “Failed to update the virus signature database. Please check your Internet connection and try later”.

What’s the problem?



I have this problem on 587, as well. Haven’t been able to update since February 5th. It keeps hanging at 50%. This is really annoying.


Your database is probably corrupted.

There are two solutions that do this:

Both of them will get the latest full AV database. After the reboot you will have to get the latest incremental updates; usually that is only several hundreds of kBytes.

Worked. Thanks. :slight_smile:


I don’t consider my self stupid, but I am definitely ignorant so please excuse any naivety on my part. I have not been able to update my virus data base for about 6 weeks - I kept trying in the hope that things would right themselves. I’ve spent a lot of time trawling around this and other forums until my head hurts; and got basically nowhere.

From what I can gather my version would seem to be positively ancient, namely 3.5.57173.439 serial no. 7925829CA709426b8B9A95F7DFEE68D8. This suggests to me that I may need to upgrade to the latest version - I’m a little surprised that this isn’t automatic, or at least semi-automatic.

Anyway, could some kind person please advise me, in simple terms, how I should go about rectifying the problem? I’ve been wondering whether to completely remove Comodo and reinstall the latest (presumably) version, however my feelings toward Comodo are a little coloured at the moment and if this was the recommended route I might find myself tempted to change to another product.

A liitle background, for many years I used Zonelarm in conjunction with CA Antivirus, everything was fine until the two products began conflicting with each other - to upgrade Zonealarm it was necessary to uninstall CA and then reinstall etc. and I thought that Comodo, having firewall and antivrus integrated together would solve the problem…Hmm, one thinks of frying pans and fires…

Thanks in advance.


Sorry to be the bringer of bad news. You cannot use the program updater to update from v3.5 to v3.14 neither can you export/import your configuration from the v3.5 to v3.14.

You will have to start from zero gain. 88)

You can get the latest version from COMODO Internet Security 3.14.130099.587 released.

Let me know if you need any assistance in the process.

Thanks EricJH

The link took me to another thread - am I correct in thinking that I need to do a complete download and install of CIS?

Sorry for being a nuisance.


Yes you need to download the installer from there, or from another place, uninstall your old version, reboot, run this clean up tool just to be on the safe side, and then install the new version.

Let us know how things go.

Hi EricJH

Excellent! All fixed and looking good.

Next time you’re in Wellington I’ll buy you a Stella Artois!

Thanks again.


I also had problems updating my Virus Database. (Same message as others here.) Since last stamped update (6 mo. ago) was just before PC took extended vacation from WWW. I concluded that you likely had a newer version. Just downloaded it into same CIS Program folder (& re-booted PC) thinking they would blend/overwrite [my PC = 32-bit XP PRO SP3] but did not.

However the notice of last update in older version has now changed to: Never Updated. But IT stills pops up the warning window for any other updates. Reading through these posts, I can see that I will need to dump the older version.

Would appreciate some input on how to do that without harming new version. Will I need to remove it from same CIS program folder? Also, when old version is removed will I be getting textboxes during PC start-up, telling me something is missing. Because last time I cleaned out Comodo’s hold queue of potential threats, something with a .DLL extension was dumped (I have no idea what) so everytime I boot up, 2 text-windows pop up telling me something “vital” is missing. They appear to belong to a toolbar I deleted; but I cannot figure out how to make them go away.

Edit by EricJH: made a paragraph structure for a better read