Can't update virus database [V6]

Hey guys,

I just noticed I have an extremely weird issue.
My virus database went totally down to version 1, I did a diagnostics check but there’s nothing wrong with the install so I downloaded the latest .cav release from some other topic.

This left me at v16669 (or so it says), once I run the updater he downloads all of the new cav’s but they are all 0 bytes in size, it does say it installed everything correctly but if I click update again it goes through the same process.

Soo I figured I’d run Cleaning Essentials to see if it updates my database through that and it starts downloading everything from v16669 which is 134 MB in size BUT it only downloads 1 MB-ish and just skips to the next one after that, the downloads are EXTREMELY slow aswell, i’m on a 120mbit connection so it should take a couple of minutes or so max. At the end of it all it spits out a “Cannot access virus signature database server” and gives me a retry button which ends up doing the same thing over and over again.

I must admit that I noticed Essentials shut down at the moment it was going to scan last week or so but I figured it was a bug and was planning on reporting it if it didn’t get fixed in the future but it most likely has something to do with this, I haven’t been protected at all yet comodo didn’t notice.

Any ideas? Maybe a remote download of all of the latest v16669 and up?
Lol version 6 seriously does not like me at all :P.

Thanks in advance.

Edit: Just found Comodo Anti Malware Database Latest Version & Additions 2022 on the forum, going to give that a go and see if i’m able to import that.

Edit again: Nope, still stuck on 16668 even after importing the new bases.cav.

Last edit: I just kept on clicking update over and over again and eventually it ended up as v16688 and couldn’t find any updates anymore shrugs no idea what was wrong with it but it seems to be at the latest database.
I did copy and paste the bases.cav I downloaded from the above link to my scanner dir and renamed the old one (which was 5MB vs the 150MB download) but that didn’t solve it right away, it might have helped though, no idea.
End Point still doesn’t work though, if I pick custom scan and deselect all the memory and advanced options it flashes open for a second and instantly closes itself without actually scanning anything.

Same problem again, i’m stuck on 16746 and i’m unable to update through the auto-updater, it says there is an error and that there’s a program update but there isn’t.

Ran diagnostics, no problems.

If i try to manually install 16755 from Comodo Anti Malware Database Latest Version & Additions 2022 using the 5.8+ .cav file it errors out after hanging on applying updates for a while saying the file source is to old to be compatible which it isn’t since I downloaded the correct file… Starts to look like a bug in v6 but i’m not able to recreate it, it just happens every now and then…

Whenever I come across problems with my computer that take an incredible amount of time to solve, I tend to share how I ended up solving the problem simply for the fact I think I could save someone going through the same trouble. Before I begin I will preface this by saying this may not work for you but after 4-6 hours of scouring through all the dribble and dead ends with the occasional pointers, this is how I ended up getting the antivirus updates working for me.

Actually it was a combination of things that got it working for me (see screenshot), but although it may take some time and several reboots I can undoubtedly say it was worth it not having to manually install virus signature updates.

1) Disable and shut down any and every program including other Anti-Malware programs you may be using, and any other program as well no matter how seemingly unrelated a problem it could possibly cause. That includes COMODO itself but other programs as well for EXAMPLE I shut down Winpatrol and Object Desktop etc.

2) Press CTRL + ALT + DELETE and Start the Task Manager. End all the Applications and go to processes and right Click any COMODO related programs which also may be running. Those will be under the description “COMODO INTERNET SECURITY”.

3) Once that’s done (and by the way these are all easy tasks to do, just time consuming) press the Windows start button go to CONTROL PANEL / Uninstall a Program / and find COMODO and uninstall it.
If you are given an error you may try another mean of Uninstalling COMODO such as the Program “YourUninstaller!”. I should mention I had this problem and COMODO not only gave me an error it did not even have an uninstaller in the program folder where Comodo Internet Security that I could locate.

4) Once that’s done REBOOT in normal mode and download CCleaner, FixCleaner and Vitsoft Registry Fix to be safe. I would also be a good idea to download the Comodo Uninstall tool as well in which you may search for on Google since that ended up coming into play. The key here is to have a COMPLETE uninstall. Once you have REBOOTED run each program several times if necessary with the exception of the Comodo Uninstall Tool which you will be using on the second REBOOT in safe mode. All these programs with the exception of the Comodo Uninstall tool have the option of backing up the REGISTRY KEYS deleted, so if anything happen you may reinstate them. That being said I have never had to do that with the programs mentions in the years I have been using them. I have had that problem with other REGISTRY CLEANERS so that’s why I mentioned what I used specifically, I would not recommend others based on my personal experience.

Once you check for invalid key /missing references / obsolete entries the it’s important to know just because you have removed them does not mean there are not related entries which also have to be removed and that’s why I recommend you start the scans over again until all the problems are gone.

5) Reboot in normal mode and open the CMD window and type SFC /SCANNOW to make sure all your system files are in check. This can never harm or compromise the settings of your computer it simply checks to see if your system files are (a) valid (b) corrupt) (c) or missing and fixed them.

What you want to do now is open the CMD window as administrator and type NETSH WINSOCK RESET just in case your Winsocks (which have to do with Internet connectivity have not been compromised). Don’t worry it does not change revert the settings in a way which will affect your access to the internet whatsover. It just makes sure they are as they are supposed to be. You will be prompted to REBOOT after you complete these two steps.

6) When you computer is rebooting press the F8 key every few seconds as soon as the system starts back up. Once you see the list of options use your arrow keys and choose REBOOT IN SAFE MODE.
Once that’s done RESCAN for invalid Registry keys as mentioned before. You might be surprised, but there are likely to still be some invalid entries even though you have just scanned and thought you had seen the last of them.

7) Now what you want to do it open the Comodo Uninstall Tool, it’s recommended you backup your registry, but even though I never did, if it makes you feel safer do it. Once that process is complete Reboot your computer in normal mode and reinstall COMODO INTERNET SECURITY and you should be able to update your Anti virus signatures to the latest definitions as before.

As a final note. I should not have to remind anyone that I tried trouble shooting the inability to download the latest updates for hours and hours and this is what ended up working for me. Hope it works for you. Good luck.