Cant update CIS anymore

I dont know when this problem started, but after trying to update, i get this error: Fehler: 0x80072f05 - Das Datum des Zertifikats ist ungültig oder das Zertifikat ist abgelaufen.

In English, something about the date of the certificate is invalid or expired. I have no idea what this means, if this is something on my end or a problem with the servers. If i try to reinstall CIS, i get the same error, so i leave everything as it is.

https://forums.comodo.com/resolvedoutdated-issues-cis/i-cant-upgrade-cis-t125972.0.html this guy had the same problem and solved it, but didnt write how. Any help would be great. Thanks.

There seem to be some issues with the automatic update.
If you like you can do an offline update on top of your existing installation.

Maybe you have read already this post and the following ones in this thread how to update offline:

https://forums.comodo.com/news-announcements-feedback-cis/comodo-internet-security-2020-v12227036-released-t125668.0.html;msg899528#msg899528

the link in this thread does not work. I get 404 not found :frowning:

For me the link works, I just clicked on it.

You can navigate manually to the link by going to section: Comodo Internet Security 2020 v12.2.2.7036 Released.

and then goto “Reply #322

EDIT:

Full path:

The Comodo Forum >
Security Products & Services >
Comodo Internet Security - CIS >
News / Announcements / Feedback - CIS >
Comodo Internet Security 2020 v12.2.2.7036 Released.

I feel like a complete idiot now :embarassed:

In your reply #322 is no link, and the one on the first page gives me a 404 error.

Something seems really off. Is there somewhere another mirror instead of the comodo servers?

For me the link below (taken from the first page) works, I’m downloading it now :slight_smile:

Offline Setup Details:

Comodo Internet Security Premium
http://download.comodo.com/cis/download/installs/1000/standalone/cispremium_only_installer.exe
Size: 80.9 MB (84,903,920 bytes)
MD5: b319a61c88f9b85f7b7680efd16bb0db
SHA1: 41c1d789a55e7c4290efef1ceb36d70c817e29dd

nope, 404 like in my attachment. i dont get it. Why should my browser block it?

Edit: Even Jdownloader says its offline. wtf.

This is odd and weird…

You don’t have any other internet connection problems perhaps?

EDIT:

I tried downloading again, it still works on my end.

no, nothing. I play, i stream, im in discord, everything. I didnt changed a thing in months, at least nothing major that would justify that. I hate that if you turn your pc on and something just doesnt work anymore without any doing on my side >:(

Edit: Could you maybe be so kindly and upload it on zippyshare or just any hoster for me to download?

You could try using Tor Browser. Paste the url in the address bar to download CIS premium.

EDIT:

This works for me too.

Thank you! Tor Browser works! For what ever reason. Hope the installer fixes the actual problem

You modified your hosts file, which you shouldn’t be doing unless you remember to undo it.

Great that you could download it :slight_smile:

You’re welcome!

uhm … ok? Cant remember ever doing that, furthermore my pc is completely new bought in January, but if you say so, i will look into that.

Edit: Holy Mother, you were right o_O there were the 2 comodo download servers written down. I swear to god i did not do that. I deleted them and now the link works with my firefox.

It was really only this fu… hosts block. Since over 1 month cause that was the last update i did manually and never noticed.

Now its working as seen in the attachment, thank you both.

probable certs invalid cause block in browsers;
connections slow, because links not 100% up;
download.comodo.com
download-cn.comodo.com

for example… :-\

wait staff fixed it…

Hello liosant,

Sorry for the inconvenience and teams are working in it.Once completed,I will notify you.

I had exactly same problem, when trying to update just single message -
“The date in the certificate is invalid or has expired”. No logs, no additional info.
Google find nothing on this.

Solution is indeed to remove from hosts file beta adreses of download.comodo.com and www.download.comodo.com.

  1. But can you please contact development team so they made this error more specific?
  2. I hope from now google will refer to this message on “The date in the certificate is invalid or has expired” search so people could find solution more easily.