Can't update CIS antivirus database [Issue Report]

I can’t update CIS antivirus database.
When I try it, after a while, I get this errro message in Spanish:
Error…
Error al actualizar la base de datos de virus.
Por favor verifique su conexión a internet e inténtelo más tarde.
I did some research in the web and I found that perhaps I should run Comodo with administrative privileges, but I was unable to do it. I got more error messages:
cfp.exe
No se puede iniciar el servicio, porque está deshabilitado o porque no tiene los dispositivos habilitados asociados a él.
How could I update the virus database?

Reinstalling it solved the problem this time. Thanks.


The bug/issue

  1. What you did: Tried to update the virus data base by clicking in “Update Virus Database” or the “Update now” button.
  2. What actually happened or you actually saw: Error message saying something like “Update the virus database failed. Please check your Internet connection and try it later” (but in Spanish).
  3. What you expected to happen or see: "A progress bar filling while downloading and updating the virus database. Then a message box saying “Done. The virus signature databas is up-to-date.”.
  4. How you tried to fix it & what happened: I tryed to run Comodo as administrator after closing all instances of it. I couldn’t.
  5. If its an application compatibility problem have you tried the application fixes here?: I don’t know about compatibility. It worked before. I haven’t made mayor changes.
  6. Details & exact version of any application (execpt CIS) involved with download link: Not applicable. It’s a Comodo issue.
  7. Whether you can make the problem happen again, and if so exact steps to make it happen: Yes. I still can’t update CIS in this, the normal way, nor in another one.
  8. Any other information (eg your guess regarding the cause, with reasons):

Files appended. (Please zip unless screenshots).

  1. Screenshots illustrating the bug:
  2. Screenshots of related CIS event logs and the Defense+ Active Processes List:
  3. A CIS config report or file.
  4. Crash or freeze dump file: Not applicable.

Your set-up

  1. CIS version, AV database version & configuration used: 5.4.189822.1355, 8482, “Comodo Internet Security” config (grayed).

  2. a) Have you updated (without uninstall) from CIS 3 or 4: Yes
    b) if so, have you tried reinstalling (if not please do)?: Yes. This solved the problem this time. I didn’t reinstall it before to post first. I should install it twice to get the antivirus. I thought the download page isn’t clear enough to be fool’s proof and I downloaded the firewall only version, without antivirus. It happened to me many times that I download the FW+AV version and when I install it the Antivirus section in the interfase is gone. I uninstalled Comodo and installed it from scratch from the same file that I downloaded (cfw_installer.exe), and the antivirus is back, and the update is working. I’d wish to not have to do it all this again. I have another antivirus installed, (things like this make me think that I really need it), but I think that an antivirus without firewall is as incomplete as a firewall without antivirus.

  3. a) Have you imported a config from a previous version of CIS: N.
    b) if so, have U tried a preset config (if not please do)?: Yes

  4. Ave you made any other major changes to the default config (eg ticked ‘block all unknown requests’, other egs here.): No

  5. Defense+, Sandbox, Firewall & AV security level: D+=Safe, Sandbox=Enabled, Firewall=Safe, AV=Stateful

  6. OS version, service pack, number of bits, UAC setting, & account type: Windows XP, SP3, 32 bit, None in XP, user account.

  7. Other security and utility software installed: CAS

  8. Virtual machine used: None.


We would very much appreciate it if you would edit your first post to create an issue report in line with the bug forum guidelines and format here. You can copy and paste the format from this topic.

To understand the reasons why we ask you to follow these guidelines please see below.

WHY WE ASK YOU TO FOLLOW THESE GUIDELINES
Bugs/issues can be impossible or very time consuming to fix if developers don’t have enough information to reproduce them. Since CIS is free, development time is limited. So if you want your issue fixed, please use the format below to describe it.

To avoid clutter, issues not described in the format below your post will not be moved to the ‘moderator verified’ issues topic. This means that the developers may not look at it.

Best wishes and many thanks in anticipation

Dennis

Thank you for your Issue report.

Moved to verified.

Thank you

Dennis

Update:

I successfuly updated the antivirus database by manually starting fisrt the Windows Installer service.