Can't uninstall

After notification that CAV will no longer update after 20th November I tried to move over to CIS. Firstly I just downloaded the CIS package and followed the instructions.

On rebooting I got a windows error messgae:-
“comodo anti-viruspyware monitor service has encountered a problem and needs to close”

I did a system restore and then uninstalled both CAV and CFP when in Safe Mode. On rebooting I get the same error message. The error points to cavasm.exe in a temporary folder in my local settings. Deleting this and rebooting does not fix the problem. A new temporary folder is created.

I tried installing CIS but the problem remains. I’m back to where I was via a system restore but would like to move over to CIS.

I’m on XP - all updated and CAV Beta 2 build; CFP 3.5.54375.427.
(One point worth noting is that CAV version via Help-About gives build but in Add/Remove in Control Panel it’s shown as version

Any help gratefully received…

I’ve got round this by scouring the pc for any Comodo leftovers both in Program Files and the registry.

There were quite a few items (I may have “pruned” the registry too hard; only time will tell) but clearing them has removed the error.

I was also getting a couple of virus alerts from CAV (taskmagr.exe was one of them) - this was after running the CAV uninstall and rebooting which was a bit of a surprise.

I have used CFP and CAV for quite some time and, on the whole, I’m extremely pleased with, and grateful for, the products. The uninstalls have been problematic though.

I’m getting the same problem.

that is comodo anti-viruspyware monitor service has encountered a problem and needs to close.

can anyone tell me how to get around this please, without having to go into registry preferably.


Hello empirebaypete

Welcome to the Comodo forum

Can you please tell us what version of CAV you have and what OS you are using as well as any other security software you have installed.

Hello shedhed

Welcome to you as well.

Glad you got it working for you.


G’day JJasper

thank you for replying.

I’m using XP all updated to latest versions etc.

I was using comodo anitvirus and firewall when I go the message that after November 20th that version would no longer be supported.

So I went to the link provided and downloaded CIS_Setup_3.5.54375.427_XP_Vista_x32.exe

I uninstalled the firewall I had and rebooted. then uninstalled the anti virus and rebooted.

then installed the new version with the CIS using the .exe I had downloaded.

everything seemed to install OK, but now i’m getting the following when I reboot.

“comodo anti-viruspyware monitor service has encountered a problem and needs to close”

At present I don’t have any other antivirus/malware software installed (should I)

I hope this is enough information for you.


Have you tried using a registry cleaner before rebooting? Several registry entries remain after an uninstall. This may be causing your problem.

In Addition to John buchanan’s advice:

Run DISK CLEANUP and Check Disk your PC then Reboot.


thanks for your replies Guys.

In answer to your questions, no I haven’t used a registry cleaner.

It’s getting late here, so I’ll run Disk clean up tomorrow.

as for check disk, apologies for my ignorance but I’d never heard of it.
I’ve googled it and I’ll take a look at that tomorrow too.

thanks for your time

Hi! (:WAV)


Hit SCHEDULE DISK CHECK if Windows ask for that then Restart your PC for Check Disk to take effect.

(Uncheck IN-DEPTH SEARCH before running Comodo Registry Cleaner)

:Beer :Beer :Beer
:Beer :Beer :Beer
:Beer :Beer :Beer

G’day Lewis.

I tried everything suggested.

That is Disk cleanup, check disc and registry cleaner.

The problem is still there, but I ran out of time. My other half needed to do
some work using the computer, and somehow Open Office refused to work.
Maybe the registry cleaner caused a problem.

So basically by the time I got Open Office working again I ran out out of time.
I’m now at work and won’t be able to get back to my computer until later in the week.



Okay (:SAD) Try to use the SYSTEM RESTORE of your PC Select the Date that your PC works fine. Update us if somethings happen.


I am having the same problem, running xp serice pack 3. tried to install new release. have to uninstall beta 2, cant uninstall beta 2 through programs or control panel HELP!!!
How do I bget rid of BETA 2 antivirus??? (:AGY)

G’day jduffyrk05.

I uninstalled by going Start…All programs…comodo…uninstall.
I’m at work on a Mac at the moment so I can’t doulble check but I’m sure
that’s the way to uninstall and reboot between uninstalling firewall & anti

I got rid of it ok that way.

I’ll be home later and intend to have another look at my computer.

good luck

I have tried the uninstall from the comodo program and it fails. I have also tried from Control panel add and remove programs. It also fails.

Has Comodo created a utility to remove the Beta 2 Antivirus? They have one for an earlier version.


I’m afraid there’s no such utility from Comodo for this software. Have you tried Revo Uninstaller?


Yes, Guys try Revo in Safe Mode, Boot up your PC and keep pressing “f8” untill you reach the dark screen. Choose Safe Mode with Networking and try Revo from there.

Hope to see you all using CAV 3.5 (CIS) soon! :slight_smile:


G’day all.

just thought I’d drop in and say I think I’ve fixed the problem.

I uninstalled comodo firewall and anti virus.

then manually deleted the comodo folders that were still on the computer.

I then ran ccleaner to check the registry whilst logging in as the two users I have.
Deleting all references to comodo.

then started the computer in safemode. don’t ask me why, i was trying anything at this stage.
ran ccleaner and disk clean up.

then started up the computer again and installed comodo.
I now don’t get the error message i was getting and comodo seems to be running.

Took a while, but got there in the end.

thanks Lewis and the others that took time to read and help.


ps. only read 3xist’s reply about safemode after writing this.

Also i’ll look at the uninstaller suggested


Moved to here. (:m*) This is a CAV 2.0 Beta uninstall issue for those new to this thread.


i can’t believe it. Are we back in 1995? What crap!!! A software that don’t unninstall! WORSE! AN ANTIVURUS WHICH CAN’T BE REMOVED!

i has the 1.1 version and nothing works to remove this shit. Plus there is no link to try the files the bats to remove so i am forced to register here to create more users in this forum.

i don’t know what more to say… i am shocked

my last try was install the new version.

which i did. Result “please a previous version is installed. Unninstall…” pathetic isent it? I really will ave to format my pc, i cant believe it.