Can't uninstall v2.4

Hi All,

This is my first time posting to a support forum; I usually can find solutions to my problems via forum trolling, but this one has me stumped. Sorry if I don’t have the protocols right.

-Comodo firewall v2.4
-Direct internet connection (formerly DSL dial-up)
-Windows XP Home SP2 w/all current updates
-Logged in as Administrator
-BitDefender AV & Webroot SpySweeper installed but disabled except to scan
-McAfee AV uninstalled (version uncertain)

I’ve been trying to upgrade to v3.0 from 2.4, and in uninstalling v2.4, I lose my ability to connect to the internet. I’ve tried many uninstallations, using the uninstall function from start>all programs>comodo>firewall>uninstall, the from these forums, and manual deletion of all comodo folders from program files and entries from registry using RegSeeker. Have also tried all above methods in Safe Mode & with Comodo’s “protect own registry keys” unticked. Each time, regardless of the method, I try to connect to the internet after uninstall and get:

Firefox – can’t find server
IE7- offline;
Network connections – shows my local area connection as connected, shared (when double-clicked, general tab shows connected, no bytes sent/<50 received; support tab shows no address type, no IP address, no subnet, etc. attempts at repairing connection “fail to query TCP/IP settings, cannot proceed”)

When attempting to start windows firewall with Comodo installed but disabled, windows firewall starts fine.
When attempting to start windows firewall after Comodo uninstall I get an error message that states that the settings cannot be displayed because “the associated service is not running, do I want to start Windows Firewall/Internet Connection Sharing service”. When choosing yes to this, I am told it cannot do so. Further investigation of the services (start>administrative tools>services>services(local)) shows WF/ICS set to automatic but not started; starting the service brings up “Error 02: the system cannot find the file specified”

Solution so far:
System restore.
Comodo v2.4 still installed

This problem was present when using Verizon DSL, and now also with RCN Broadband (cable).

I have a high degree of confidence in the Comodo firewall, and want to step up to v3.0 given my current always-on internet connection; also interested in Comodo AV & malware when my for-pay software expires, but this problem uninstalling v2.4 gives me pause.

If formatting C: and reinstalling XP is the only solution, I’ll do it, but will be totally annoyed.javascript:void(0);

Clumps of hair are accumulating ‘round my desk. Any help would be appreciated.

Machine specs: AMD Athlon 64 X2 4200+; MSI MS-7270 mainboard; 2GB RAM; EVGA 7900 GS; CoolerMaster Centurion case; abit AirPace Wi-Fi PCIe-X1; on board sound

Are you letting your system reboot after the uninstall? I’ve had this issue before, and it was usually because I did not reboot after install/uninstall.

Hi Justin,

Yes, I rebooted after uninstall.

Here’s the funny thing…
Since my post, I updated to XP SP3, and my problem is gone. Go figure.
2.4 is uninstalled, I have my internet connection.
I loaded up v3.0 to begin the setup, and was hit with a barrage of pop-up windows for permissions for every single process on the planet. I realize this is what it’s supposed to be doing, but my wife needed the computer for work and would go batty for all the interruptions, so I uninstalled v3.0 to return to it when I had more time to set up trusted apps, etc.

Big mistake… uninstalling v3.0 got me the same “can’t connect to the internet” problem as before.
System restore.
I’m going to do a more thorough install of v3 over the weekend, but do you have any thoughts?


What if we install 3.0 back on the computer, but this time let’s put it in training mode for both the firewall and defense+ so it can learn your system.

That should stop the popups, and after a few hours of computer usage, go ahead and set both the firewall and defense+ to your previous settings (be it safe mode, clean pc mode, etc…). That will cut down the initial popups by a huge margin. And the popups you do receive, you can set as you like.

Try to keep in training mode for as little time as possible, because the firewall is simply learning in this state. It won’t block anything.


Forgot to add to the last post (it was late and I had forgotten that this was the main reason for the uninstall mentioned in my last post):

When v3.0 finished with install and ran malware check, the main screen came up and had a yellow “-” in the summary>system status pane. After about ten seconds, it turned to a red “X” and said that the COMODO Application Agent was not running. Diagnostic utility said there were problems with the install, would I like to fix them.
Well… yes I would, thank you.
Failed; would I like to create a diagnostics report. Yes, please (attached).

Tonight I tried to install from safe mode, but attempts to turn off Windows firewall resulted in the same “WF/ICS not running” problem as from my first post. I installed CFP anyway and rebooted. App Agent not running, no ability to fix. System Restore.

Install CFP from normal (non safe mode) Windows, with WF off (no WF/ICS error). App Agent still not running, no ability to fix.

I never used to like System Restore. To think I once considered turning it off…

Oh yeah, and setting the firewall and defense+ sliders to training mode saved a serious sprain on my clicking thumb.

[attachment deleted by admin]

I’ve asked our developers to take a look at the diagnostics report.

Thanks, Gents

Additional info:
Since diagnostics report was generated, I’ve uninstalled BitDefender AV, SpySweeper, and Netcraft toolbar. Still experiencing same issues, except:

Internet connection returns after second reboot (or choosing “no” to COMODO uninstall’s request to reboot after uninstall, and then manually rebooting)… go figure. Unsure if 3 anti-malware apps I removed had this effect. I suspect not.

Only remaining issue is v3.0 not initializing.

Thanks for all your help and advice so far.

I followed the “comprehensive” uninstall directions from the v3.0 forum, manually deleting all traces of COMODO, Firewall Pro, and CMDAgent, etc., then ran the zipped batch file for good measure.

After a reboot and fresh install of v3.0, I’m happy to say I have a big green checkmark in the summary>system status pane of the firewall window. All systems appear to be go.

I’ll let you know if I have any more issues.

Just a couple of questions before I go:

  1. Would installing CAVS & BOClean be redundant to Defense+, or create any conflicts?
  2. I noticed that the Ask Toolbar and SafeSurf are separate apps in Add/Remove Programs. Can I uninstall Ask Toolbar without comprimising SafeSurf?

Thanks a million for your help. (R)
Peace, Erik

  1. Yes CAVS’ HIPS could cause issues, it would be wise to disable CAVS’ HIPS. 2 HIPS running at once is not wise.
  2. If they are seperate toolbars then uninstalling one should be fine, I cannot assure this as I do not use them.