can't uninstall/reinstall comodo firewall

I have no idea how to remove it…

[attachment deleted by admin]

Please see this.

Hello,

I had comodo firewall version 3.xx, after updating for version 5 it crashed. I can connect to any wifi or wired network, but I cannot use any browser, http or https. However, updating trough some software works, I can connect skype, msn and so on.
I tried lots of times to uninstall, either through its own uninstaller, either by third parties (ccleaner, revo uninstaller, your uninstaller, ashampoo uninstaller, perfect uninstaller, and none worked). I also removed manually all the entries in the registry, but still doesn’t work. I reinstalled the new version serveral times, but did not work neither.
THe only way for me to use a browser is on Safe Mode with Networking.
Does anybody has any other tip to repair it? I want to get rid of comodo.
thanks

Hello;

Please See here
or
here

Please report back after you have done either of first method or the second method

Jake

hello

I had searched for help before, and I’ve tried all the methods in these topics, till I decided to write. I just could not see any reference from people that could be having the same access on safe mode… I don’t know if there’s anything to do, anything that is loaded on normal startup and that’s not on the safe mode…

thanks

I don’t believe you can upgrade directly from V3 to V5.

Have you tried reinstalling V3 and then uninstalling using Revo uninstaller?
Perhaps then you can install V5.

I ve tried both. I’ve spent some 5 months wihout updating COMODO, as I had no internet connection for a while. I’ve installed again v3, then tried uninstall, it uninstalled, but still not working. Then I tried installing v5 and then uninstalling, but nothing. Then installing again v3, and uninstalling, nothing. Now I accidentally deleted the v3 installation. There is nothing about comodo in the register. I also deleted the files in the system32\drivers and I managed to renamed guard32.dll to a .bak file

And browsing still working on safe mode…

Let me try to summarize what’s been done. Please correct me if I’m wrong.

  1. You’ve tried upgrading directly from V3 to V5.
  2. You’ve tried uninstalling V3 and installing V5.
  3. You’ve tried uninstalling V3, reinstalling V3, uninstalling V3, and installing V5.
  4. You’ve also tried uninstalling using installers (such as Revo, etc…)
  5. You’ve tried following any other steps in my article.

All of these have failed to help.

Have I missed anything you’ve tried?

You could also try what was suggested in the 2nd half of this reply.
Also, are there any other security programs running on your computer? If so then I would recommend uninstalling them until we get this solved.
Also, are there any other programs you have installed on your computer that could possibly be interfering?

Thanks.

It looks like there are left overs of the Windows Installer causing the confusion here. Try Windows Installer Clean Up utility to get rid off Windows Installer left overs.

Once they are gone you should be good to go. Then run this clean up tool in Safe Mode to get rid of the actual installation.

Hello,

I did all the process, nothing yet. Still browsing without problems in safe mode.
Using the windows installer clean up utility, comodo was not even on the list. Shall I reinstall Comodo V5?

thanks

Hi Chiron,

I have installed here in my computer

  • Spybot Search and Destroy
  • Malware Bytes Anti Malware
  • Avast 5

I have here Windows XP Media Center SP3

As I said, it’s quite strange cause I can connect to my wireless network, I can use MSN, Skype, update my Avast, even automatic security downloads from microsoft, but I cannot browse.
I thaught it could be a problem with the DNS, then I changed it but nothing. THen I tried also to enter the IP address of a website, but it cannot resolve it neither. When in Google Chrome and normal mode, I received the following error:

Unable to connect to the Internet
Google Chrome can’t display the webpage because your computer isn’t connected to the Internet.

You can try to diagnose the problem by taking the following steps:

Click Start, click Run, type %windir%\network diagnostic\xpnetdiag.exe, and then click OK.
Error 106 (net::ERR_INTERNET_DISCONNECTED): The internet connection was lost.

May be the firewall driver is left behind. Read the following.

How to uninstall the CIS firewall driver when it stays present after following this or using the clean up tool? Look up the properties of the network connection, select the Comodo Firewall driver and uninstall it. See the image.

Now you should be good to go