Can't turn off Network Discovery or File Sharing in Vista

I installed comodo in basic firewall mode. Can’t seem to turn off Network Discovery or File sharing in Vista Home Premium 64. Searched this forum and the net and can’t find any solution, really starting to bug me.

When my network was detected by Comodo it gives you the option to make your computer visible on the network for file/printer sharing etc, I definetly did not tick the box for this as I don’t want my computer to be visible on the network.

Any help would be gratefully accepted.

No guarantees but something you might try:

Double click the firewall icon to open the GUI.
Click Settings.
Click General.
Unckeck Automatically detect new private networks.
Click OK.


Tried that, didn’t work. Thanks for trying though.


I have the same problem on Vista Home premium. I even tried switching on windows firewall and selecting to turn off file sharing as this was recommended on several forums. However, as soon as I switched windows firewall off again sharing was back on. It seems as soon as windows firewall is turned off file sharing is enabled when another firewall is installed - I had the same issue with the pre-installed Norton firewall that was on the pc before I installed CFP3.

It is irritating not being able to turn sharing off so I hope someone may post a solution here…