Can't share media with Xbox 360

Hello All,

I really am new to the Comodo firewill I have installed. I am glad I found this forum as I know I’ll have lots of questions. I have a wireless Linksys WRT54GS Ver.6 router connected to my PC and my xbox 360 has a wireless connection. Today I wanted to listen to some music thru my 360 and it would not connect to my PC (in the past this process worked fine with Norton). However, ever since I installed CPF I have never once had a problem connecting to Xbox Live. When I clicked MY PC under media shaing I get an error message saying “a firewall may be blocking the connection.” So, I clicked the DEFENSE tab, DEFENSE+SETTINGS, and DISABLED the SECURITY LEVEL to see if things would work, which they did.

There was another thread I found that I thought may help me define a new trusted zone and then set the rules but it appears to be for an older version. If anyone could help me I’d appreciate it. Thanks.


Is there something I’m doing wrong that no one is giving me an answer? Am I posting in the wrong place?


The principles for the previous version still apply in V3, but things are in different places.

To define the zone for your LAN, open CFP and click FIREWALL → COMMON TASKS → MY NETWORK ZONES. Include all the IP requried to allow traffic on your LAN (including any routers and, of course the Xbox).

To create the equivalent of a network rule in CFP V3, oen CFP and click FIREWALL → ADVANCED → NETWORK SECURITY POLICY → GLOBAL RULES. Click ADD, set up the rule as per the post covering the previous version, but under SOURCE ADDRESS and DESTINATION ADDRESS select ZONE and use the zone you have just created for your LAN. Click APPLY. The rules may take a minute or two become effective.

Let us know how this goes.

Ewen :slight_smile:


Fantastic! I’ll give this a shot and let you know. Thanks!



So far it’s not working. Here’s exactly what I have thus far. Upon looking back at my trusted zones I noticed my router wasn’t in there either. So now my Xbox and router have been added. Do I use both of the rules for the router also? Thanks.


The zone definition must include all devices that will send/receive information to/from the PC running CFP. Assuming that your LAN is running addresses in the 192.168.1.X range, make your zone definition - This would cover all devices.

What relevant entries are inthe firewall logs?

Ewen :slight_smile:

You’d need to extend that address range to to catch the broadcast traffic (LAN filesharing and name resolution, UPnP queries, and other such noise).

Damn you - putty fingers!

Good, I’ll try that. Hopefully it’ll work because things weren’t working this way:

I created a zone (Xbox) and entered a range of 192.168..100 thru 192.168..254

I then created the following rules:

Rule 1

Action = Allow
Protocol= UDP
Dir.= In
Source IP= Xbox
Dest. IP= Xbox
Source Port= Any
Dest. Port= 88

Rule 2

Action= Allow
Protocol= TCP or UDP
Dir.= In
Source IP= Xbox
Dest. IP= Xbox
Source Port= Any
Dest. Port= 3074

I’ll change the range to 255 and let you guys know. Thanks for hanging in there with me.


Still nothing. Based on my previous post settings can anyone make heads or tails what I’m doing wrong? Thanks.


Is there anything in the firewall log? It could be there is some traffic being blocked somewhere.

If there is nothing obvious in the log, then it may be there is a combination of rules that is causing the problem. Try running the Configuration Reporting Script (sticky topic at the top of the forum page) to get a listing of all the rules. Just the firewall rules, as that script can produce a huge amount of output.

I can see in the Firewall Events where the IP address of my 360 has been blocked a bunch. Do my settings look correct? I am afraid to rum the Configuration tool as I’m a computer simpleton and it sounds like I could really mess things up using it if I don’t know what I’m doing. Thnaks.


Could you post your log? The details of what’s being blocked may give some clue as to what the problem is.

About your settings being correct, I don’t know. It’s because I don’t know what your settings are. The Configuration Reporting Script is just a report generator. It doesn’t have any capacity to make changes to your machine. It’s quite safe to use. If you run the script, you’ll get a compact report that you can post here, and then we can work thru your settings in detail.

Sure, how do I post it?

Export your logs to HTML and then attach them to a reply to this post.

Ewen :slight_smile:

I have converted to HTML and saved to my desktop but how do I post it here? Thanks.


When you click “Reply” See “Additional Options…” ? Click that, Click Browse… Then find your desktop and upload it.


I tried that but it didn’t work because the file is an htm file and apparently I cannot upload that type of file to the forums. To start I wen to VIEW FIREWALL EVENTS > MORE then I highlighted every event , right clicked and clicked EXPORT TO HTML and chose to save to my desktop. What am I doing wrong? Thanks guys for hanging in with me.


Hi Jon,

Sorry about the brevity of my answer, I should have been more detailed. Mea culpa.

Assuming that you have exported the logs as a HTML file to your desktop, do the following;

  1. Do a right click on and empty portion of your desktop
  2. On the context menu that appears, select NEW → COMPRESSED FOLDER
  3. This will create a compressed folder on your desktop and will be waiting for you to give it a name.
  4. Give it a name like LOGS.ZIP (N.B. The dot and the “zip” at the end of the name are critical)
  5. Press ENTER
  6. The compressed folder will now have the name you’ve just given it.
  7. Drag the HTML log file on top of the compressed folder and release the mouse button.
  8. This puts a copy of the HTML file in the compressed folder.
  9. Log into the forums and post a reply to this topic, attaching LOGS.ZIP (assuming you followed the example above)
  10. Voila!

Hope this helps,
Ewen :slight_smile:

You guys are awesome! Thanks for all the help. Let’s try this:

[attachment deleted by admin]