Can't reinstall firewall * already installed on your system ... [RESOLVED]

COMODO Firewall is already installed on your system Do you want to un-install it

Hi there!

I have uninstalled Comodo (with windows add/remove prg) (for testing KAV 6.x) and then deleted manually left files in prg directory) and even also cleaned registry but now i’m not able to install it anymore again, each time i run the setup i’ve this message : COMODO Firewall is already installed on your system. Do you want to un-install it?

If I choose YES, nothing happened (no activity). Are there any hidden files that I need to delete before reinstalling? Any solution?

Please help!




almost one week and still no clue on how to fix that? ???

i used Comodo Cleaner (batch/reg) but since it’s for alpha version only it doesn’t help…


Sorry you had to wait for so long! This is not the case normally! :slight_smile:

Here I found two situations that might cause this problems

This link has the reasons why this could happen!

But I think this is your issue!

Let us know the results!


thanks a lot, the 2nd solution has worked !! (V)


Good to hear that! :Beer


Great work guys! This topic will be marked as resolved and closed for other users’ benefit. freshhh, should you need it reopened, just PM a Moderator (please include a link) and we’ll be glad to do so.