Can't paste into vbulletin forum via firefox - SOLVED


(SOLVED - see below)

I hope I am in the right place and provide enough info - I would really appreciate some help please.

I recently installed Comodo firewall. I’m really pleased with it, because I have had a lot of problems recently with trojans and other nasties and I think this is the right software to keep my PC secured, now that I have the PC clean and free of nasties.

I use a vbulletin forum a lot, and I often paste text into the posts I am making there. I use Firefox browser and I’m running windows XP. I’ve mostly got the hang of the firewall, but there’s one persistent problem - it won’t let me paste into the posts.

It will allow me to copy/paste into other applications, but not this particular vbulletin forum via firefox.

I have found a few different threads here regarding similar pasting issues, but none of them have been entirely the same and unfortunately they have not helped me to solve this problem.

If I open Comodo firewall, click on defence+, click on ‘view defense and events’ then the most recent events shown are ‘application=firefox’ and the flag is ‘direct keyboard access’.

I am hedging my bets that this is a log of where the firewall program is stopping me from pasting?

I have read some of the relevant parts of the manual, but unfortunately I cannot find out how to instruct the firewall that pasting into the forum via firefox is not a security risk.

As far as I can see from ‘my pending files’, firefox is not running from the sandbox - when it first put firefox.exe in there, I clicked the buttons on the alert to tell the program to remember not to sandbox firefox. Also, the mouse software I use (logitech trackball) has also been added to ‘my own safe files’.

If anyone could enlighten me on how to resolve this I would be very grateful, as even though I’m quite patient and experienced, I’m in that situation where I feel a bit like screaming and I’m getting recurring nasty thoughts about what I’d like to do to the hackers that put me in this mess in the first place - you know what I mean?!! I’m sure the answer is right in front of my nose, but I still can’t see it for love nor money!

Many thanks in advance, apologies if I’m being a numbskull. I’ve underlined my main question above.


OK, I went into defense+ > advanced > computer security policy

Then I highlighted firefox and clicked edit. ‘Use a custom policy’ was checked and I clicked on ‘access rights’ - I then noted that alongside ‘keyboard’ it said ‘blocked’ - which was the only one set to ‘blocked’, so I then changed this setting to ‘ask’ and it now seems to be solved.

So this is now solved and unless you think it would be helpful to others to leave the post here, please delete it for me if you would be so kind.

Thanks for a great firewall and obviously it’s reasonably intuitive, or else I wouldn’t have been able to solve this myself, being a bit of a numbskull. Now for some serious pasting :wink: