Can't open pop up form tray

Hi all

Recently i’ve installed firewall with defence+ 4.0 (XP32, SP3). I was making some configuration changes and now i can’t access pop up menu from system tray icon, when defence+ isn’t disabled. Even in training mode it doesn’t show up. I don’t know if i messed something or i messed something and a bug showed up :wink:
Other thing is that i can’t use keyboard controls while playing game, until D+ is disabled (only esc works). Game has set all actions to allow.

Thanks in advance.

I am in a lazy mode as it is late. CIS stores its rules in the registry. So, system restore could do the trick for you. However my laziness it is a working method… O0

After reloading a system restore point i’ll loose also firewall settings. Is there any way to save it? (beside backuping it driectly for the registry). Exporting seems to export all settings. I didn’t find any option to export only firewall settings. Also i didn’t play with gray programs including CIS custom policy.

This strange behaviour applies only to comodo icon. Rest of them can be normally accessed from tray even in paranoid mode.

You can only export a total configuration. Only you know what you are doing you could export from your registry.

Can you show a screenshot of the Defense + logs? May be it gets logged. They can be found under Defense + → Common Tasks → View Defense + Events.

When D+ is enabled it logs only SendMessage event from the icon. Now i also discovered that when D+ is enabled i can’t access to programs in start menu. I click start button, hover over all programs and then the list shows up, but i can’t select anything (on menu and task bar). Sometimes it even disappears (menu). I must then activate any window, to make things ‘normal’. This comodo logs as a InstallHook in shell32.dll.

Changing D+ behaviour for explorer.exe doesn’t make any differences.

In attachment screenshot made after few tries of clicking comodo icon in system tray.

[attachment deleted by admin]

In the default rules CIS should be able to receive Windows Messages. Did you change that?

I don’t think so. Settings in ‘COMODO Internet Security’ programs group:
Access rights: all set to allow, run program - ask
Protection settings: Window Message and WinEvent hooks - no, Memory Acces i Termination - yes

Problem seems solved. I’ve changed in ‘all applications’ protection settings, all 4 things to no. I would appriciate any comments why this helped.