Can't mount a backup image.

I have a .cbu file from a backup I made a bit ago, it’s just a backup of the complete C:/ drive. I need to get some files off of it that I lost during a reformat(forgot to save a folder).

Anyway, I can’t get the image to mount at all. I click mount and while it shows in windows explorer I can’t access it and it always says 0% in the mounted drives section of Comodo. Screenshots below.

Not sure what I am doing wrong. ???

[attachment deleted by admin]

Dang, no one knows at all? By the way, I can’t mount any of my .cbu backups. =/

Hi please check diagnostic report to see if the program is installed correctly.
Go to Windows → Run → type “%TEMP%\CB diagnostics report.txt”

Thanks

Don’t see anything that would suggest it’s not.

19.04.2011 18:48:52 Comodo BackUp 3.0.171317.130 
19.04.2011 18:48:52 Checking if restart is needed...
19.04.2011 18:48:52 No restart needed... OK!
19.04.2011 18:48:52 Verifying your windows version...
19.04.2011 18:48:52 64bit...
19.04.2011 18:48:52 Windows 7
19.04.2011 18:48:52 Windows version check OK!
19.04.2011 18:48:52 Current user has administrator privileges!

19.04.2011 18:48:52 Checking if Synchronization service is running...
19.04.2011 18:48:52 Synchronization service is running!
19.04.2011 18:48:52 Online Storage service is running!
19.04.2011 18:48:52 Checking CBU.exe integrity...
19.04.2011 18:48:52 CBU.exe is ok!
19.04.2011 18:48:52 Checking CSE.exe integrity...
19.04.2011 18:48:52 CSE.exe is ok!
19.04.2011 18:48:52 Checking vss_xp.dll integrity...
19.04.2011 18:48:52 vss_xp.dll is ok!
19.04.2011 18:48:52 Checking vss_vista.dll integrity...
19.04.2011 18:48:52 vss_vista.dll is ok!
19.04.2011 18:48:52 Checking vss_s2003.dll integrity...
19.04.2011 18:48:52 vss_s2003.dll is ok!
19.04.2011 18:48:52 Checking libeay32.dll integrity...
19.04.2011 18:48:52 libeay32.dll is ok!
19.04.2011 18:48:52 Checking ssleay32.dll integrity...
19.04.2011 18:48:52 ssleay32.dll is ok!
19.04.2011 18:48:52 Checking SynchronizationService.exe integrity...
19.04.2011 18:48:52 SynchronizationService.exe is ok!
19.04.2011 18:48:52 Checking COSService.exe integrity...
19.04.2011 18:48:53 COSService.exe is ok!
19.04.2011 18:48:53 Checking ShellExtension.dll integrity...
19.04.2011 18:48:53 ShellExtension.dll is ok!
19.04.2011 18:48:53 Checking cbufs.sys integrity...
19.04.2011 18:48:53 cbufs.sys is ok!
19.04.2011 18:48:53 Checking BDisk.sys integrity...
19.04.2011 18:48:53 BDisk.sys is ok
19.04.2011 18:48:53 Checking CBReparse.sys integrity...
19.04.2011 18:48:53 CBReparse.sys is ok
19.04.2011 18:48:53 Checking cbvd.sys integrity...
19.04.2011 18:48:53 cbvd.sys is ok
19.04.2011 18:48:53 Checking cbvdbus.sys integrity...
19.04.2011 18:48:53 cbvdbus.sys is ok
19.04.2011 18:48:53 Checking cbunat.exe integrity...
19.04.2011 18:48:53 cbunat.exe is ok!
19.04.2011 18:48:53 Checking if BDisk.sys is working properly...
19.04.2011 18:48:53 BDisk.sys is working properly!
19.04.2011 18:48:53 Checking if cbufs.sys is working properly...
19.04.2011 18:48:53 cbufs.sys is working properly!
19.04.2011 18:48:53 Checking if CBReparse.sys is working properly...
19.04.2011 18:48:53 CBReparse.sys is working properly!
19.04.2011 18:48:53 Checking if cbvd.sys is working properly...
19.04.2011 18:48:53 cbvd.sys is working properly!
19.04.2011 18:48:53 Checking if cbvdbus.sys is working properly...
19.04.2011 18:48:53 cbvdbus.sys is working properly!
19.04.2011 18:48:53 Checking windows task scheduler functionality...
19.04.2011 18:48:54 Windows task scheduler is working OK!
19.04.2011 18:48:54 Diagnostics ran successfully!

Do you have any security software that might interfere with CB?