Can't Login to EasyVPN

I keep getting the error message “The login information you have entered is invalid.” At first I thought it was a program issue but it seems to be more than that. When I tried to login to my account online through the web page it denied me there as well. Seems to be an issue at the server point where the login credentials are stored.


Several people have had similar problems ( including myself :frowning: ) I waited several days, not ideal, but was then able to log in again after changing my password. I had raised a support ticket and the problems are being looked into by the development team.

Thanks for the info. I tried changing my password several times but I did that within a few hours of each other. I will try to change it again and see what happens. Also just to note for any of the techs working on this, I installed the program on 3 different computers. 2 PC’s and 1 laptop. All have the same result. Which brings me back to believing that its a centralized issue.


It does seem to be a centralized issue as that is the same as happened to me. It is as though you have been locked out of your account, the same as if you enter an incorrect password more than three times on a network and you then have to unlock it via the Network Admin Account, but as I say it did seem to reset after a few days and I was than able to log in again and have had no further problems now for several weeks.

Hope this helps, if not then raise a support ticket and they will assist.

Add me to the list as well :-\

I did the usual pass reset and so forth and it has not worked. I tried logging in from different machines and no go.

I submitted a support ticket. Amazingly, I got not one but two replies over the weekened! Unfortunately, the answer was bizarre as the support person specifically referred me to this very thread!!

The problem is on their server side and it fails to authenticate. It seems other people are having issues with login (some say the program gets stuck on the login with no error). Regardless, as of now this is not a reliable program and don’t throw away your alternatives for intranet messaging or secure messaging until they can fix it on their end.


same here since i have upgraded to last beta :-TD

I am having the same problem. I registered in January 2010 and since then had to replace my hard drive. After installing the program on my new drive I tried to login and it says it is invalid. I have reset my password several times and no luck.