Can't install last version, always finishing by 1603 error

I try hard since 2 days to re-install last comodo firewall version, but it always finishing by a 1603 error :frowning:

Of course I read this forum, and try the Chiron method (Comodo Forum), with using also ccleaner, but without success for now.

In details, I try : uninstall normally by windows + boot in safe mode and using COMODO Removal Tool 2014 - Mods version + uninstaller tools V0.3b + reboot + ccleaner 3 passes for registry + again boot in safe mode and using COMODO Removal Tool 2014 - Mods version + uninstaller tools V0.3b
Note that I need to use the system recovery to get back keyboard, mouse and others when I use to much option of uninstaller tools. I finally use only uninstall Comodo internet security

But even with all of that, each time when I arrive at 99% of installation, I have this 1603 error :frowning:
For the installation, I just install the firewall (without geekbuddy, dragon and antivirus), and without changing my DNS and adding a toolbar.
I already have avira installed on my computer, I deactivate it when I try to install comodo firewall
I use windows 7

I really like comodo firewall in the past, so what I can do to have it again working on my computer?
How can I know what is the problem exactly? Did I need to uninstall avira completely?

Have you uninstalled CIS 8. I’ve had this problem when uninstalling CIS 8 . Then CSI 7 or CIS 8 gives this 1603 error . Hat to reinstall windows as SFC said files damaged and can not be repaired.

Hope you get a sollution for this.

My last CIS (7 or 8 I don’t know !) was corrupted because some files was removed.
I try to re-insntall first last version without doing anything, but since that I have this 1603 error :frowning:

And I really don’t want to re-install all my system!

Try this most likely for your error https://forums.comodo.com/format-verified-issue-reports-cis/cis-8-cannot-be-neither-installed-nor-updated-from-cis-7-m1372-t108265.30.html

If not working try my reinstall guide https://forums.comodo.com/install-setup-configuration-help-cis/most-effective-way-to-reinstallupdate-cis-to-avoidfix-problems-t58620.105.html

Thanks Rigo!
With setting English language, for non unicode programs and for comodo, it works!
So now I have comodo working, but my system is partially in English… 88)
And I don’t really want to experiment to put it back in French (my own language), because if I read correctly the post you point, at least 1 user have problems doing that…

You welcome. Can’t help you further since I didn’t follow the whole thread and never had this problem, up to you to try.

FANTASTIC! So, after unsuccessfully tried many solutions, uninstallers, cleaners, Windows installer fixes, etc., etc., AT LAST we’ve all have the SOLUTION for ERROR 1603! This error is completely on Comodo’s head! It’s not because of ■■■■ copied from MS site encrypted folder, nor removable drive or SYSTEM user rights!!!

New versions of Comodo has an installer error, IF your System locale in Regional settings (default setting which is used by OS default for non unicode apps!) is different from ENGLISH (US) - it will give you the fluff!

So, if you have an error 1603 on 99% of COMODO installation - just change your System locale to ENGLISH!

That’s IT!

Hope, Comodo will fix this error soon, and put in order their support & beat test team & web site! I’ve downloaded same product from different links on official comodo site, and I’ve got 4 different files with names, size & versions!!! Really a shame!!!

Comodo - stay cool as you was in versions 3,4,5,6! Do not let marketing shit loose lots of users, money & future! For now… we still love you, but. think!

Good luck!

z

Jaf, btw, it’s just an installer issue (seems caused by last after installation adv. window pop! :wink: So, just you can change your locale setting back after installation & reboot! :wink:

Can you please follow this guide to install CIS?
https://forums.comodo.com/install-setup-configuration-help-cis/cant-install-cis-solved-t109641.0.html;msg796691#msg796691

Dear yigido - your guide is a completely different story - not our case at all!!! That’s one more of solution which will not help in case of installing Comodo 1st time on clean PC & fluff of on 99% with 1603! :wink:

Have the same error 1603
NOTHING of this solutions are helped me.
And yes, I have SSD drive, my Windows installed at it. Hope, COMODO coders already know about SSD :smiley:

Windows 7 Ultimate 64 bit
Windows installed at SSD, hot plug parameter in BIOS is off, so it’s not removable drive

Locale settings are Russian.

I never used COMODO before
At this comp before was AVAST antivirus and ZoneAlarm firewall. Sure, I’m uninstalled it 1st.

So, I’ve tried: COMODO removable tool, Ccleaner, a tons of restarts between cleanings, changing locale settings to English (US), changing install lang to English, changing install drive from C (SSD) to another (usual HDD).
SYSTEM user have a full rights to any drives and there is no encrypted folders sure.
Have no idea what to do else.

And I’ve installed the same CIS at another comp with the same Windows and locale settings with the only difference - that comp do not have SSD.

SilverWF, My solution for locale issue ONLY if you got an error on 99% of installation. Do you? If not, if this is 1st install or reinstall from other version?

Try

  1. SFC.EXE /SCANNOW
    and
  2. Microsoft Easy Fix solutions have been discontinued - Microsoft Support
    plus
  3. cleaners made by comodo fans like Uninstaller Tool.exe or batches…

Comodo loves only clean PCs! :wink:

Yes, I have this error at 99%

  1. Tried before
  2. No errors found
  3. Tried Uninstaller Tool v0.3b, then restart, then this tool again

Still have this error.
Have no idea why COMODO hates SSD

Also, I’ve tried to install just COMODO Firewall - guess what? The same 1603 error

I “fixed” this error by reinstalling my Windows - installed it at HDD now. And Comodo installed OK after this.

It seems to be an permission error in the Windows system:

I have Windows 10 now and the latest Comodo Firewall won’t install because of this error, and i’m still looking for to solve this problem.

Ultimate Solution:

1.Start Windows in SafeMode with Network Support. İts important that you start safe mode with NETWORK support.

2.Open cmd.exe (start->cmd)

  1. Type this

    REG ADD “HKLM\SYSTEM\CurrentControlSet\Control\SafeBoot\Network\MSIServer” /VE /T REG_SZ /F /D “Service”
    you can Copy and Paste it, but paste only with mouse, ctrl+v will not work. If you cant paste it, type it exactly with the spaces and ".

  2. Type

    net start msiserver

5.Close the cmd.exe and start the installation of Your Comodo Software in Safemode.

  1. Restart your PC and enjoy your fresh Comodo Software.

You can remove the registry entry if you wish.

Start->regedit
Remove the entry in this folder ‘MSIServer’

Hkey_Local_Machine ->SYSTEM ->CurrentControlSet ->Control ->SafeBoot ->Network ->MSIServer

What worked for me was deleting two comodo folders in the hidden AppData folder after booting to Linux. If