Can't install CTM

I tried to install CTM on my Windows 7 32-bit pc. But I get the following error message: CTM supports only simple volumes.

First I checked my 2 drives and realised that the first partition on my 2nd drive is a ‘primary’. I changed that to ‘logical’ as it contains only data. But still I get this error message.

Can it be that my ramdisk is the reason?

Anybody an idea how to fix this?

I’ve just uninstalled my Ramdisk. The first error message disappeared, but I got a new one (in german, my system language) later in the installation process, in the middle of ‘Please wait while the setup Wizard installs COMODO Time Machine’:

Bei der Installation diese Pakets ist ein unerwarteter Fehler aufgetreten. Es liegt eventuell ein das Paket betreffendes Problem vor. Der Fehlercode ist 2203.

“When you install this package, an unexpected error has occurred. There may be one problem with the package. The error code is 2203”

This is a tip of windows installer not ctm.
Maybe the ctm package has been destroyed.
Suggest you download ctm again and install it with Anti-virus software closed.

Hope it helps.

I solved the 2nd Problem with the 2203-Error Code. The problem was due to deleting the Ramdisk, because I previously had changed the path of the Windows Temp to the Ramdisk.

After that, I tried installation again. Everything seems fine, Comodo was copying files … when I suddendly had a BSOD!! I’m glad that my system booted without problem afterwards.

I’m a longtime user of RollbackRx and have currently installed CTM on my netbook without problem. But if I still get that much trouble installing it on my PC, I rather prefer using RollbackRX again.

On your PC,
Have you installed (and then uninstalled) Rollback Rx yet?
If so, please check whether the regkey of SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\Rollback Rx exists or not.
I think it is the reason.

You can refer to the previous post.;msg366347#msg366347

Hope it helps.

Thank you for your support. I manually deleted all entries in the registry named rollback resp. rebit (another software I’ve tried) and could install CMT afterwards without any problem. Thanks!

It’s our pleasure. Have fun.
If you encounter any problem, please feel free to contact with us.
Thanks for your support too.
Best regards.