Can't install Comodo Firewall

I had Comodo Firewall installed for awhile, then for hard-to-explain reasons, I had to uninstall it. The other day I was ready to reinstall it, but during the setup and even once it was installed, it would not initialize and I got a few blue screens. In fact, on the Comodo window itself, it said, something to the effect of “Network Firewall not working etc etc, do this, this and this to correct it”. Well nothing I did worked!

I should also mention that I also tried to install CIS after this, but had the same problems. So obviously it’s conflicting with a previous version of Comodo. Isn’t there a removal tool that you have available that I could download to get rid of remnants of Comodo? Or, as I think I may have read somewhere, the removal tool is in the setup?

Also, when I go to your homepage, I can’t find the download for the Firewall 3 anymore! Everything is now CIS. Even when I clicked on Firewall Pro, CIS started to download!

CIS (3.5.57173.439) is the latest Firewall Pro, but includes CAV3 and Defense+.
You do not have to install CAV when you run the install program. Simply unselect CAV to just install the firewall.
Have you tried using a registry cleaner (then reboot before trying a new install) to fully remove CFP?

I had this problem on 2 brand new systems, 1 x Vista, the other XP Pro. Both were new & neither would accept CPF, they’d get so far through the installation & just freeze. I was forced to install (dare I say it here) Zone Alarm f/w which went on without any issues.

I recently had to uninstall CIS because of what I thought was a problem with the antivirus, but on reinstalling it, now the firewall won’t work. Diagnostics detects a problem with the installation, but it’s not something that it can fix. Have already downloaded Comodo’s registry cleaner, and cleaned out and tried reinstalling CIS multiple times with no succcess. Help please?

@gleow. Try uninstalling CIS in safe mode and then clean the registry with Comodo registry cleaner. Then install CIS again in the regular mode.

@mr v6. Make sure all instances of a previous firewall are uninstalled. Zone Alarm seems to have a habit of not completely uninstalling. Try this tutorial: .