Can't install Comodo AV after install Comodo Firewall

I installed Comodo’s firewall, but then tried to install their AV, and it gave me an error message.

It says I have uninstall Comodo Internet Security 4.x (firewall).

Should I uninstall the firewall, install the AV, then try to install the firewall again?

I find it strange that I their firewall is clashing with the AV installation.


go to start, programs, comodo, add remove components, make sure both are checked. Follow the install procedure.

I’m having the opposite problem; I installed the AV first and now the firewall is claiming I have to uninstall the AV before it can be installed. What do I do, and what are this mysterious “installation procedure” you mention? I have found no such document.

I recently installed the updated Firewall and GeekBuddy, but Windows Security is now telling me I do not have anti-virus software, even though I still have my original Comodo Internet Security programme (which I can’t work out how to uninstall)

Languy means to simply follow the installation process.

Apparently it is mandatory to uninstall the av first if you want to install the firewall. Please follow what the installer tells.

When you’re using v5 of the av you can keep the av definitions if you want; it will save you from the long download of 110 MB after installation. Copy bases.cav to another folder and follow Where can i download the latest full AV database? for the procedure how to successfully copy the bases.cav to the installation folder.

You got me confused here. Where you using firewall only and updated from v4 to v5 using the program updater?

Does your current Comodo have the virus scanner installed? If so then reset the security center to set it straight:

Open a command prompt by clicking Start → Run. Type cmd and click OK.

In the command prompt window, type NET STOP WINMGMT /Y and press ENTER.


Type EXIT and press ENTER to close the window.

Restart the system. Windows should start normally, but you may be prompted to restart the system once more to complete the changes caused by resetting the core repository. You may also need to restart once more if Windows Security Center still does not detect your security product.

Tried to reset security center but access denied

You probably need to start the command prompt as admin. Follow How to Open Elevated Command Prompt with Administrator Privileges in Windows Vista and try again.