Can't Install CIS

After having a problem with updating on CIS 3.8 , I decided to revert to v3.5. So I un-installed 3.8 but when I tried to install 3.5 the installer kept telling me that I already had a version of CIS on my system.

I tried cleaning the registry with Comodo Reg Cleaner, but that didn’t help.

I have searched both the hard drive and the registry, and deleted every reference to Comodo, but when I try to install either version it says I already have CIS, and asks if I want to uninstall or upgrade it, Yes or No.

Whichever answer I choose, it just closes the installer without doing anything.

What is the installer detecting ( and where is it ) ???.

Can anyone suggest what I can do to get one or other version installed.

I have revived my previous AV and Antispyware for the moment, but I am currently relying on Windows XP firewall, which has a rather poor reputation.

So a prompt solution would be MUCH appreciated, if anyone has one.

Thanks, Leo.

Why do you want to go back to 3.5? It is impossible to update mawlare signatures because 3.5 uses old database system so it is bad idea. If you don’t like heuristics simply deactivate it an you will have almost 3.5. About uninstalling CIS… you have to delete all comodo registry keys( I had to do this manually) and after rebooting all comodo folders in program files, program data, document and settings etc. but sometimes it doesn’t work.

The reason I was trying to go back to V3.5 was because 3.8 would not update for me, either auto or manually.

Right now I would settle for either one but I can’t install any version.

As I said in my previous post I have searched both the hard drive and the registry, and manually removed every trace of CIS that I can find, but something must still be lurking in there somewhere, and the installer is detecting it and will not proceed with the install.

Regards, Leo.