Can't get utorrent to work properly

Hi all!

Anyway, just installed Comodo, it seems really good. The only problem is that i’can’t get utorrent to work properly, i can’t get any incoming connections and that somewhat slows thing down. When i turn Comodo off everything works just fine. I tried adding some rules like, allow everything in my ip address and port, also allow everything in/out for utorrent than allow everything in/out for my ip address and port, but nothing seems to fix the problem, the utorrent port checkup utility always says that the port is not forwarded properly. When utorrent starts it says “unable to map UPnP port” in its logs section.

Any and all suggestions will be greatly appreciated!

Thank you all

Did you even read my post, or have you just proceeded to bashing.

Anyway i did as all of those faq and me myself have said, does anyone have any helpful ideas, maybe something application based or some weird network rule.

Thanks in advance

Disable the UPnP feature of utorrent and it will work.

This applies to every application emule, azureus, dc++, etc.

I have U torrent too and i cant get it work. I have tried to disable UpNp but it doesnt make a different. also i have defined a new trusted application to U torrent. but nothing work (:AGY)

I don’t use utorrtent (I use Bittorrent), but I have a sneaky suspicion you might be missing a network rule.

According to my How To - Understanding & Creating Network Control Rules properly FAQ…

[u][b]Rule D[/b][/u] Now sometimes a response to our communication request is going to [u]come in on a diferent port[/u]. Take [u][b]Bittorrent[/b][/u] for example, [u]we request[/u] a file and the download starts on a [u]predetermined/configured TCP/UDP port[/u], i.e. 6881 by default. For each file we want to download simultaneously, we need a new TCP/UDP port, i.e. to download 4 we would need 4 ports... 6881, 6882, 6883, & 6884. Similar to opening the ports on our Firewalls/Routers (without the need for forwarding, as the communication is already [u]coming into our PC[/u]).

I want to… Allow requests for incoming TCP/UDP communication (on ports 6881, 6882, 6883, & 6884) from any PC on the web to my PC

Using the Rule building blocks: (just as with Rule B, we could select to Add a new Rule and move it above Rule A, or you could right-click Rule AAdd RuleAdd Before [either way works])
Action: Allow (we want to make a rule to let requests be made)
Protocol/Direction: TCP/UDP In (Even though we asked to download a file [feels outbound], the response is coming back on a different port than our request; therefore, it is going to look like the remote PC is trying to request in inbound communication)
Source IP: Any (Let the request come from anywhere… somewhere on the web in this case)
Remote IP: Zone: [LAN] (remember, InBound Rules will always have a Remote of our PC [whether we specifically set its IP address, its subnet / Zone, or use Any])
Source Port: Any (we don’t care what port it left the remote PC on in this case)
Remote Port: A set of ports [6881,6882,6883,6884] (we only want to allow the remote PC to sent to the ports we configured Bittorrent to use)

I dont know how to do rules and there is no things like remote ip and in comodo… :frowning:

here is a screenie of what the network rule looks like within CPF

[attachment deleted by admin]

Thx for screenie it helps and I make some own rules. What is Rule building blocks ? does it matters where you put own rules in permission table? anyway I make 1 rule for Utorrent and it seems to work now. :slight_smile:

Excellent, glad to hear… let’s hope it works for urch

If you want to understand what I was referring to about “building blocks”, you’ll need to read my How-To article that I posted a link to.