Can't get this new Comodo contraption working

I used Comodo years ago with expected success. Now I am lost with the new interface.

  1. I tried downloading, it was real slow. It didn’t work the first time, and I had redownload it.

  2. The second time finished the following day and I just tried installing it.

  3. When running, the bloated menu options freeze telling me I have never updated. Does this freeze mean it is downloading files? I see no progress meter. After 20 minutes of waiting without any sign of life from the bloated Comodo menu options window, I uninstalled it.

  4. When it installed, internet access was blocked. Yes, it is secure now, but I could have saved the internet money and not installed Comodo if the solution was to not use the internet.

  5. I want a SIMPLE, SIMPLE, SIMPLE, firewall like I saw years ago that listed ports and such. I will be looking at other firewall programs because Comodo has become too bloated bloated bloated. If I can’t get internet, a window is frozen when I initially launch, what good is it?

  6. The main issue at hand is that I am connected to a wireless router. Until yesterday I had the only desktop. Now that another person has their desktop connected to this router, I see their computer name.

It is inaccessible, but I don’t know if my computer is inaccessible also. I was hoping a firewall program like Comodo was years ago might help provide useful information. I am not too concerned about others with desktops seeing what I have, but I do not want the company we work for to be able to access this. I assume some kind wireless option would be the way to do this, as the 4 internet ports in the router go to “us” and not the company. If I am correct, how would I block the wireless options, so no one could access my computer?

It sounds like there was something wrong with the install. Please try reinstalling it by following the advice I give in this post.

Please let me know if doing so solves the problem or not.

Thank you.