Can't get my webservers working when CPF is on

Hi everyone! I have a computer running Windows XP SP2, and I have installed CPF v3. I also have a virtual machine running Ubuntu Server through VMWare Workstation.

                           Win XP Machine                     Ubuntu Server

INTERNET ========= (200.49.xx.xx)
(192.168.0.1) =========== (192.168.0.2)

The thing is that I’m running Apache in my Win XP machine, listening to port 80, and in my Ubuntu Server too, listening to port 80 too. I’ve configured Win XP to redirect outcoming connections from the Internet through the port 8080 to the 192.168.0.2:80. So, when I access my public IP through port 8080 I see the Ubuntu Apache, and if I do it through port 80 I see the Win XP Apache…
Everything works fine when I have Comodo Firewall disabled. If I turn it on in any mode (Training, Train w/safe mode or Network Policy) I can keep accessing my Win XP Apache but I can’t access my Ubuntu Server through port 8080. I tried all kind of configurations, policies, etc but I can’t get it to work! I’ve even tried an “Allow from any to any from any port to any port” rule, and it doesn’t work! It just works OK when Firewall is disabled… Can anyone help me?

Well, it seems it’s a really hard to solve problem… :frowning:

What entries appear in the log (GUI->firewall->view firewall events) after unsuccessful attempts?
What global block rules do you have? What rules do you have for “Windows Operating System” in application rules if any?

I just checked my application policies and I saw that I hadn’t added a “Allow TCP port 8080 In” policy under “Windows Operating System”… I added that and now it works!

Thanks for your help! =)

PS: I wonder why adding a global “In/Out, any port, any IP” rule didn’t fix the problem, though…

Hello,

Similar issue here : with VMWare 6 on Win XP SP2
All VMWare initiated traffic is identified by CPF 3 as “Windows Operating System”.
So, it’s not possible to make “clean” allow rules, because allowing outgoing traffic from VMWare means allowing this traffic for any “Windows Operating System” subsystem.

→ are there any plans to further distinguish the source of this kind of traffic ?

→ and by the way, I wish I could at least create these explicit rules for “Windows Operating System”, but how can this be done with the GUI ?? How do I tell Comodo that the application name is “Windows Operating System” ?

thanks !

Hi guix314,

It’s normal thing because VMWare initiated traffic is not related to any process (applicationless or routed traffic). And this kind of traffic always related to “Windows Operating System”.

Create rules for “Windows Operating System” by defining specific network zones (e. g. VN and local machine etc). So all WOS traffic can go between your zones without blocking, but is blocked in other cases.

GUI → firewall → advanced → application rules → add → select → running processes → windows operating system.
Move it to the top of the list and create whatever rules you want. You may even delete all your global rules if rules for WOS are configured properly and firewall is in custom policy mode.

Hmm, this leads to what I think is an issue with my CFP installation : When I ask for
GUI → firewall → advanced → application rules → add → select → running processes,
I always get an empty list !

Any advice for fixing this ?

thanks for your time and for your great firewall tool

OK, please see screenshot to make sure it is the right list.

I don’t know how to deal with this problem. Maybe logon-logoff or restart? Or reinstall CFP…

[attachment deleted by admin]

And this is what I get.

OK, I will perform a reinstall

[attachment deleted by admin]