Can't get Java to install [RESOLVED]

I can’t get Java to install. I tried to update to no avail, then deleted Java but can’t get it reinstalled. I believe it is a Firewall issue. What do I do to my firewall to let Java in? I am using Chrome, and the Java message I get says “The installer can not proceed with the current internet settings”.

This only became a problem after I got Comodo and tried to update Java.

Try to disable(Exit) CIS and your resident AV. Then try again to install Java. This is Java what? Java 7 update 2…?

Just did that. Turned off CIS, then disabled the firewall. Same error message.

Not sure what version of Java, just went to site and asked to download current version. Downloads at chromeinstall.exe.

Turned off or exit? I encountered that with an XP SP3 machine with AvastFree. I set Avast to be enabled after restart. Shutdown (exit) CIS (right-click the tray icon>Exit).

Well you might wanna try checking first what Java you have downloaded. I personally do not let Java update itself. I download the latest version from the site and install it manually(install over existing). When “install over existing” can’t be possible (as with my experience in the XP pc) I disable AV/firewall>uninstall Java with RevoUninstaller>restart>install manually again.

Let’s wait for some more ideas. The guys might have some better ideas/tips :slight_smile:

I did the right click exit on CIS.

I had already deleted Java previously so no way to install over existing.

I’m runnning Vista if that’s any help to anyone.

Right clicking on CIS tray icon and choosing “exit” won’t disable the FW; it just close CIS GUI. If you want to disable the FW you have, after right clicking CIS tray icon, chose Firewall and then “disable”.

Could you check in FW > Network Security Policy > Application Rules if there isn’t a block rule for Java.
Check also in Defense+ > Computer Security Policy > Application rules if there isn’t in the rules for Java some blocked items.

You could also try to install Java trough Internet Explorer to see if that makes a difference

Please use the ‘offline’ installer from this page;

Windows x86 Offline or the Windows x64 (only if you need it on x64).

Once downloaded start it with a right mouse click ‘Run as administrator’.

Thanks Ronny, your fix seems to have been the cure I was seeking!

Looks like the online installer was blocked somehow… glad it’s fixed now :-TU