Can't get Internet Access

I have Comodo Internet Security Premium installed. Everything works well when I’m at home, but I just took my laptop to the local library and was unable to get internet access. The wireless network was found and connected to, but I just couldn’t get a connection to the internet. The assistant said the problem might be my firewall.

When I got home, everything worked again without any problem.
Is there anything blocking new connections, or do I need to make changes to any configurations to allow internet access?

Any helps would be appreciated.

At the library try disabling Block fragmented IP Datagrams.

Thanks Eric, for your reply. I just tried disabling the ‘Block fragmented IP Datagrams’, and that doesn’t seem to work. I still can’t connect.

Any other suggestion? Anything else I need to change?

Thanks for your assistance.

Thanks Eric, I’ve got it working now. I didn’t realise my network connection was set to use a predefined DNS, so changing it made it work.

Thanks again :slight_smile: