Cant get Comodo configured to allow ssh from internet

I have freesshd installed on my XP box. I can ssh just fine from my linux machines inside the local network ( I have a port forwarded on my router to port 22 on my XP box. When I try to ssh to my external IP, comodo blocks the incoming connection. If I turn comodo to allow all, it connects. I tried setting up a network control rule to allow TCP/UDP, any IP for both and 22 for both ports but still no luck. If I change the ports to any for both it works again. And if I change the dest port to 22 and the source port to any it works. But any value of source port doesn’t work anymore. I am afraid I don’t understand the source/destination stuff it seems.

Any help will be appreciated.

Hi nowhere,

To sum it up,if your computer is initiating the connection then your computer is the “Source”,the computer receiving that data is the “Destination”.
So if another computer is trying to connect to your`s,you are the “Destination” and they are the “Source”