Can't get Comodo 4.1 or 5.0 Antivirus to work :-(

I previously installed CIS 4.x on a Windows Home Server, it works fine without any issue but I didn’t like the firewall interface, so I uninstalled the Suite and replace it with Comodo Antivirus.

Now i have few problems.

  1. When I try to run “Update Virus Database”, it said “Update failed. Error code 0x80004002, No such interface supported”. I can manually update the virusdef with base.sav though.

  2. I can save, open, run eicar.com when Virus Defense is set to On Access or Stateful. If I right-click eicar.com and scan it, it detects the threat.

  3. System Status says “Defense+” is not functioning properly. I click “Run Diagnostics” and no error detected.

Hope someone can help me to fix the problems.

Thanks
Andy

try just reinstalling the whole suite and just disable the firewall and whatever else you dont want to use. this will probably help a lot with bugs like that

I can’t because this the install is on a Windows Home Server (based on Windows 2003 R2). I can’t connect a monitor handily like typical PC. If I install the full suite, the firewall will block RDP access.

I tried to installed the full Suite without Firewall, same problem.

Hopefully Comodo will have fix for me soon :frowning: :frowning: :frowning:

Just uninstalled 4.1, ran cleanup tool, install 5.0 antivirus mode.

Same error with Windows 2003.

When try to update virus difinition:
“Update failed. Error code 0x80004002. No such interface supported”

And it still failed Eicar test.

:frowning: :frowning: :frowning:

Officially Windows Server 2003 is not supported.

What failure do you get with the eicar test? Remember CIS does not have a web shield that will check the incoming data.

I downloaded eicar in various form from web, then saved it to the HDD, opened it, executed it, copied it with no complain from CIS.

Also I couldn’t update the virus definition.

I am not sure I can be of help here. Windows 2003 server is not officially supported and I am not running it myself. I have seen only a couple of reports where people reported it worked on Win 2k3.

Do you have any other security or network related programs running in the background? Try disabling them and see if that helps.

Hi Eric, appreciate your attempt anyway. I want to install a AV on my Windows Home Server box (Windows 2003 R2 kernel), I used to have CIS4 working but then it stopped working after I uninstalled it and installed CAV4.1. I tried put the full suite CIS 4.1 back and it remains broken.

Is Endpoint Security Manager a good alternative (officially support Win2003)? Does it has a big footprint? I see it requires MSSQL as well. Is it a time limited trial?

thanks

ESM is for free when using up to 5 user I think. ESM is for deploying software. It is not a security application its self for as far as I understand it.

I was thinking about the “no such interface supported” message. Try installing the latest Visual c 2005 and Visual C 2008.

I uninstalled C++ 2008 dist, rebooted, uninstalled CIS5, rebooted. (C++ 2005 wasn’t there)

Installed C++ 2005 dist and C++ 2008, rebooted

Installed CIS5 again.

Same problem.

However, before the reinstall, it seems CIS5 was able to automatic update the virus def. Just whenever I tried to do a manual update, I got the “no such interface supported” error.

Also CIS reported there is a problem detected in Defense+ before and after the reinstall.

Can the av update its self automatically? Then leave it that way. It checks every half an hour. Who needs manual; especially with the cloud bringing the latest detections straightaway.

Do you have other programs running that interfere with networking? VPN client, Netlimiter, Zenmap with associated PCAP driver? Try disabling them.

Have you ever had other security program installed? Try the following.

We are gonna take a look to see if there are some old drivers of your previously uninstalled security programs are still around. Go to Device Manager → View → show hidden devices → now look under Non Plug and Play drivers → when you see a driver that belongs to your previous security programs click right → uninstall —> reboot your computer.

When the problem persists make sure there are no auto starts from your previous security programs. Download Autoruns and run it.

This program finds about all auto starts in Windows. This tool can therefore seriously damage Windows when not handled properly. After starting push Escape and go to Options and choose to hide Windows and Microsoft entries, to include empty locations and then push F5 to refresh.

Now check all entries to see if there are references to your previous security program. When you find them untick them. After unticking reboot your computer and see what happens.

I found a few McAfee items in non-PnP drivers. I could uninstall all but the “McAfee Inc. mfehidk”. The mfehidk is like a ghost, even if I disable it, another instance will re-appear after next reboot.

Do you know how to completely remove mfehidk?

thanks

May be try McAfee’s own removal tool: http://service.mcafee.com/FAQDocument.aspx?id=TS100507 .