Can't get CIS 4 to block outbound

I was real happy with CIS 3 because I felt like I could control out bound spy applications, but now with 4, and I have scoured the forums on how to replicate 4 to act like 3 in regards to selective blocking by asking, and I cannot get it to block.

I have it set to proactive security, block, ask and log all unmatching requests, and still, it lets out apps that
I do not want them to phone home.

TIA for any advice on this, otherwise, I need to go back to V3.

[attachment deleted by admin]

Under Firewall/Firewall Behaviour Settings make sure the box to create rules for safe applications is not ticked.

Move the firewall security level slider up to custom policy mode and on the alerts tab move the slider up to medium, high or very high, depending on how much information you want to capture.

Perfect, that worked great, thanks!

Also, that block and log rule under Comodo Internet Security only applies to actions of CIS itself, not to anything else.