Can't empty Recycle bin due to busy file -

I installed the latest update (, and restarted) just before I tried to empty my Recycle bin. I was not able to because a file was busy. After another restart, I got by that file but encountered another busy file. I looked at my pending list and found the offending file. I removed it (and all others in the Recycler folder) and placed CFP in Installation mode. I had no more trouble emptying my Recycle bin. I have seen problems on other applications before in older versions of CFP concerning busy files. I suspect the same problem.
Is this a bug? Perhaps CFP is not releasing files properly.
Comments would be appreciated.
I did a search and found only one reference to ‘recycle’ (not applicable). I suspect the search is again not working properly.

Well from what I read your saying that the D+ pending files is holding back windows from deleting said files? Ok well if that is the case you can do 1 of 2 things.

  1. Put D+ into training mode, and all files will be accessible (as they wont be added to pending)

  2. Go into D+'s pending files section and remove everything from the list. That will let CFP know that those files have been cleared by you, and you should be able to delete those files.

Thanks for your reply, Info-Sec.
I was able to get the delete completed as I stated in my first post. What I was wondering was:
Is this a bug?
Shouldn’t CFP release these files?
I don’t think I should have to reduce my level of protection to be able to access files CFP has referenced.

Well the idea of those files that are held in ‘My Pending Files’ is that only files that you have cleared, and that you have reviewed will be able to do operations on your Operating System. So infact it is not a bug, but rather a well functioning module that had a little inconvenience. Just curious, what is your D+ setting?

Thanks again, Info-Sec.
Even when I am trying to empty the recycle bin? Perhaps if I restored the file but not when it is in the bin.
I do understand your point and will keep it mind when I encounter busy files.
My Def+ is set to Clean PC Mode.