Can't Edit Custom Application/Global Rules Descriptions

I just started using Comodo Firewall Pro and I really like it so far, but I have a problem. I’ve created some custom rules in the Application and Global Rules sections of the firewall. But if I try to change the descriptions of any the rules, no matter how many times I click ‘Apply’ in any of the windows, the changes won’t stick. I’ve even tried restarting the firewall, but still no luck. Is there a way to fix this?

Hi tmr250z, welcome to the forums.

I believe this is a bug (reported here). You can work-around the problem by clicking on any tab below the description field, you don’t need to change anything (it forces CFP into realising the description has been changed).

Thanks for replying, kail.

I’ve just tried what you suggested, but it’s still not working.
I added some words to a rules description, selected one of the the tabs below it, clicked ‘Apply’, but still no change. :frowning:

You are right… for me it only works the first time I change the description of any particular rule. Any subsequent changes using that method do not work. So far, I can only get it to work by ticking or un-ticking the Log field to force the Description change on Apply. Not very satisfactory, since you need to re-edit the rule to put the Log field back to what is was in the first place.

Obviously, a more complex bug that I first believed. Rather odd actually.

OK, the ‘ticking or un-ticking the Log field and then re-editing the rule to put the Log field back to what is was in the first place’ trick worked for me. :slight_smile:

But yeah, that’s a weird bug. Hope it’ll be fixed in the next version. Thanks for your help. :slight_smile:

Excellent, I’ve updated the original report with this additional information. Thanks for reporting this to us. :slight_smile: