Can't download from Firefox

I’ve been running Firefox in Comodo Internet Security’s Virtual Desktop environment for months and regularly downloaded files. But sometime during the updates of the last week or so it has become impossible to download the majority of file types: pdfs, mp3, etc., etc… In fact, the only thing I have been able to download was a simple copy of a web page. When I click the Download arrow in the menu bar, the download dialog opens: but as soon as I select the ‘Save’ option, irrespective of what default directory has been set, a yellow spot appears beside the Download arrow in the menu bar, and clicking the arrow displays the download as ‘Failed’.

If I try the same thing with Chrome, the download works OK, and it also works fine when Firefox is run outside the Virtual Desktop: so it looks as if the problem is down to some kind of adverse interaction between CIS and Firefox. Any suggestions?

As of today, I have the latest updates to CIS, plus the latest release versions of Firefox (54.0.1) and Windows 10 Home (64 bit).

Have you tried running the reset the containment task and try downloading with firefox again inside the virtual desktop? Does it work when you run firefox from the CIS widget?

Yes, I have tried resetting the container via the Containment Tasks, ‘Reset the Container’ option. I also just tried opening Firefox via the widget. But neither of these solves the problem.

I’ve had the following response from a query on the Mozilla forum:

As a note to provide more context: when you click a link or button that triggers a download, Firefox starts downloading the file to the Windows TEMP folder. After you specify a save location Firefox will move it there once the download is complete. On the other hand, if you choose an application to open the file, the file will remain in the TEMP folder. If neither of those work in your sandbox, check with Comodo on whether any configuration changes are needed. If only the file move is a problem, I'm not sure what's causing the new incompatibility: Firefox has done it that way for years.

As a result, I’ve run some additional tests, and found that I get the same error regardless of which option I choose. Nothing appears to happen until I select either ‘Open’ or ‘Save’ and if I look in the Windows/Temp folder, and in the interim nothing appears to have been saved in either the root or in VTRoot. But as soon as I select ‘Open’ or ‘Save’, the spot appears beside the download arrow, which bounces up and down a couple of times, and clicking on it then displays the Failed message. So I’ve been wondering if there is some kind of permissions issue. I have been logging in with admin privileges: but when I attempt to view some files or folders, I am still asked to confirm before proceeding.

Try adding firefox to the detect shellcode injections exclusions to see if that helps.

Thanks for responding. HIPS was actually disabled, as it turned out. (I probably disabled it when troubleshooting another problem a few months back.) Just to make sure, I re-enabled it, checked ‘Detect shellcode injections’ and added firefox.exe to the exclusions list: but the result was the same. I also tried disabling all my Firefox extensions: but still no joy. :frowning:

Can you run and attach a diagnostic report?

I’ve created the diagnostic report and tried twice to upload it: but although it was listed as an attachment, neither it nor my accompanying comments have appeared.

I’ve just tried again to send this report … this time from Google Chrome. Again, no success. But, looking at the Attach notes, I see that it says the maximum attachment size is 15,500KB. The report size is 412,842KB: so how am I supposed to send it?

Just do it via Dropbox or one of the other free file deposit providers . . . then send the link via pm to the recipient

Your diagnostic report seems fine but you did have multiple crash memory dumps of the cis.exe process which is why the report was so big. I can only suggest to perform a clean uninstall following this guide and install again. But try with a default config before importing from a saved one or make changes.

Thanks very much for taking the time to look into this. Unfortunately, I’m up to my ears in work; and have been forced to resort to using Chrome instead of Firefox for now. Last time I tried a clean uninstall it took ages to get everything reinstalled and working the way I wanted it again. We’ve got builders scheduled to come in next week: so it could be several weeks now before I can find the time to attempt this.