Can't download files anymore

I have Windows 7, 64-bit and ESET Smart Security 8.0.312.3, but I really don’t think this is an antivirus issue. My internet connection is via fiber-optic network, so it’s basically the fastest you can get.

For two days now I’ve had trouble downloading files from the internet. Yesterday a client sent me a 632 MB video file using WeTransfer.com. I left the download running for ages and it reached the point where it said 1 s remaining, and there it sat for an hour before I canceled the download. I hoped that the file would have been completely downloaded after all, since it said 632 of 632 MB, but no, the file was deleted when I canceled. The second time I tried downloading it, it worked.

Today I’m trying to download a new version of Cute FTP and the same thing happens, although the file is “only” 19.6 MB. It downloads to the last MB, then it sits there saying “1 s remaining” and nothing happens. I’ve canceled and restarted the download twice to no avail.

TIA

Hi ChangelingSE,
Try with all 3rd party add-ons disabled.

Try clearing your downloads history.
Ctrl+J

Kind regards.

I deleted the download history and looked in the add-ons. I have no third-party add-ons apart from AdBlock Plus (technically an extension rather than an add-on, but the main heading is still add-ons), which I duly deactivated, but it has no effect. My attempt to download Cute FTP stops at “one second remaining” and never goes any further, no matter how long I wait.

I did manage to download a video file from a client yesterday, though.

The Add-ons heading also includes plug-ins – I have Acrobat, Office, Dragon, Java and Flash plug-ins. I could see how AdBlock could inhibit downloads, but can the Acrobat or something plug-in stop them?

Oh, this is interesting. I have two instances of Cute FTP downloading, and one of them tells me it’s downloaded 39.1 of 19.6 MB. Ummm… What?

And now I deactivated all the other stuff, the Acrobat and Office and Flash and Java, and deleted the download history again AND restarted IceDragon to make sure that it didn’t have any of the active things registered in its cache or whatever. Tried the Cute FTP download again and it went to “one second remaining” – it says it’s downloading 19.6 of 19.6 MB – where it’s now been for five and a half minutes.

Something is definitely wrong here. Does anyone have more suggestions?

Have also tried deactivating my antivirus while downloading, still no effect.

Hello ChangelingSE,

I know you said you deactivated your antivirus while downloading and it didn’t help, but just to make sure this isn’t causing your problem you should try setting the browser.download.manager.scanWhenDone to false in the about:config window in CID.

1) In the Location bar, type [b]about:config[/b] and press Enter.
    "This might void your warranty!" warning page may appear. Click I'll be careful, I promise!. 
2) In the Search field, type [b]scanWhenDone[/b]
3) Double-click on the [b]browser.download.manager.scanWhenDone[/b] setting to change its value from true to false. 

If the above doesn’t work, then try downloading the file again and when it gets stuck downloading, right-click on the download progress bar. Pause should come up as one of the options (see image1 below), click on Pause to pause the download, then right-click again on the download progress bar to bring up the Resume option. Click on Resume to see if the download completes. Let us know if you are able to pause & resume your download and if the download completes.

If none of the above helps, then more info is needed from you.

  1. Can you download the file using wget, IE or another browser?
  2. Have you always had this problem since installing CID or is it just a recent problem?
  3. Have you installed download manager add-ons in CID, then uninstalled them?
  4. Have you tried a download manager to see if it solves your problem?
  5. Are you using a new/different router?
  6. Have you tried bypassing the router and connecting your computer directly to the cable modem?
  7. Can you download files with extensions other than .exe or video files?
  8. Can you download small files?

Regards,
gs22

[attachment deleted by admin]

So. Well, it seems that the main problem was CuteFTP’s download site, combined with a random problem downloading a big film file from a client. My computer tech couldn’t download from the CuteFTP site either. And other things have now downloaded without incident since then.