Can't disconnect ADSL connection

I’m having the same problem as the guy in this thread:,2078.0.html

I see the advice, specifically:

Do this.
“Security” - “Network Monitor” and create a rule +Add

Action: Allow
Protocol: UDP
Direction: In

Source IP: Zone [Select your ADSL modem here]
Destination IP: Zone [Select your ADSL modem here]
Sorce Port: Any
Destination Port: Any

Your ADSL modem needs to allow a UDP-Incoming: upnp-mcast(1900).

However, I simply can’t figure out how to set my modem as a Zone. My IP is dynamic, and I have no idea what IP I’d enter to specify my modem.

Please help, as I love Comodo, and would hate to have to move to another firewall. Thanks in advance =)

Welcome at the forums (:HUG)

You do not need to add a rule and you must not add a secure zone since you don’t have one. Can you try to disable Do protocol analysis and check if it resolves the problem?

ps. please report back if it does.

Hi, thanks for the fast reply.

I did as you said, and disabled protocol analysis in Security/Advanced/Advanced Attack Detection/Misc. Sadly, this made no difference.

The issue I’m having is exactly the same as the guy in the thread I stated, so at least I know I’m not going mad!

It looks like, in the absence of a solution, I’m going to have to give up on Comodo for the time being, a shame as it truly looks like a fantastic product.

Any other ideas before I throw in the towel?

Sometimes a reboot is needed.

Try the following:

  1. Open a Command Prompt (DOS) window.
  2. At the C:/ prompt, type ipconfig/release and press Enter. The system
    releases the IP address.
  3. At the C:/ prompt, type ipconfig/renew and press Enter. The system
    displays a new IP address.
  4. To close the Command Prompt window, click on the X in the upper right
    corner of the window. You have completed this procedure.

this will renew the IP address and after that give it another try.

ps. you have the default options or have you modified the settings of CFP?

Tried everything you suggested. Offline, it reported ‘windows IP configuration’, online ‘The operation failed as no adapter is in a state permissable for this operation’. Tried it several times, online and off, rebooting plenty. I’m using a 100% reinstall of windows, with the Comodo settings untouched at default.

Still no luck, disconnect hangs.

One more thing to note:

With Comodo set to ‘Allow All’ the problem persists, making one thing it’s not related to Comodo’s rules etc. However, with Comodo uninstalled, the problem disappears. Reinstall Comodo, and it’s back. I’ve tried this four times back and forth.

Seems like the issue is something more fundamental with Comodo’s install. I have a Speedtouch 330 ADSL modem, by the way.

Thanks for the help, shame I can’t seem to solve this one.

Hmm, this one will be hard to resolve.

Please go at the advanced tab of CFP and enable skip loopback tcp connections (probably it is not the problem but check this just in chase.

Then go at the varius sections of the advanced tab and disable one by one the features and try again each time you disable one of them. No need to reboot. Just wait a few seconds between disabling a feature and trying to disconnect.

ps. it is the only way to troubleshoot it and find where is the problem. After that we will report it to the develop team. :slight_smile:

Well, I tried unticking the options one by one as suggested. The thing is that when I try to disconnect, the service crashes in such a way that I cannot reconnect at all. Therefore, I’ve just been through one hec of a lot of reboots!

Looks like it’s back to Netveda for me, for now. I do hope you can fix the problem in a future update, as, for me, it spoils an otherwise excellent product. Of course, if anyone else has ideas on how to fix this, then I’d be more than happy to see your replies.

Once again, thanks for the help.

I am sorry about that. :-\

Let’s hope that with the version 3 this will be fixed.

ps. Can you send a private message at edeppi. the member that had the same problem and ask him for help?

Does your network card use the RealTek 81XX series of chip? Various driver versions for this chip can, under certain circumstance, be left in a hung state on LAN disconnect and require a hard reboot to reinitialize, which pretty much echoes your description.

If so, please update to the latest drivers from the RealTek site.

Hope this helps,
Ewen :slight_smile:

Thanks for the reply, but I have my network card disabled in Device Manager, as I’m not on a network and connect using a Speedtouch 330 Modem pluggeg directly into a microfilter. In either case, the card uses the SiS 900 chip.

Will send a private message to the other user with the same problem as suggested. Cheers all.

Please try us again on V3.