can't delete .exe file after it is run in vista 64bit

I had a very unusual problem with comodo internet securirt 3.10.102363.531 on my vista ultimate 64 bit with service pack 2:

in short:
when ever I execute an exe file, I can’t delete it afterwards.
I can delete it after restart.

That happens for almost every exe file that is run on the system no matter where.
I run a console based exe file (that has no windows GUI) and it was not locked and I could delete it. but that for some dos based programs only.
in sum up:
OS: Vista Ultimate 64bit service pack 2.
using CCLEANER - but only after the problem happend.
using windows defender - tried disabling not good.

it is not a security problem because if I don’t run the file, I can delete it, and if I restart I can delete it.
the file isn’t locked nor open by other process because:
I could not find any handle on file, and the file is not locked, since I can move it to another folder, as long it is within the same volume, I can’t move it between disks(volumes), and I can rename it. (you can’t move or rename an open or locked file), and I can change its content (not overwrite).
it doesn’t happen just because of the exe extension, some dos file with same extension can be deleted after run.
please see the following vistax64 thread - it has all the details:

at the end removing comodo internet security - solved all my problems, to bad i liked it.

BTW - disabling the defence, firewall and antivirus did not solve the problem only uninstall.

Same problem, except I am using WindowsXP 64bit SP2 with CIS 3.10.102363.531.
If the antivirus is disabled before I start the executable I can delete it. If the antivirus is running when I start the executable I cannot delete it anymore even if I disable the antivirus before trying to delete it.

I am also experiencing the same issue with Vista 64 and with CIS 3.10.102363.531 - a good example to demonstrate this issue is Locknote available from Steganos. It is impossible to delete or modify this file once it has been downloaded to the desktop or a directory and Locknote no longer works as intended.

I’ve tried disabling UAC and taking ownership of the file but that doesn’t work either.

I had this same issue on Vista Ultimate x64 w/ CIS 3.10.102363.531, but the new update to 3.11.108364.552 seems to have fixed it for me.