Can't connect to VPN while Comodo FW is active

Setup is Win7, IPSecIKEv2 VPN Server, CIS 6.3, Avast 9, DNSCrypt to OpenDNS

Due to the conflicts with Avast in prev. Version i used another firewall till now, but i decided to test the new Version (uninstalled previous with Revo Uninstaller Pro & still scanned for leftovers with jv16pt i use just for detailed and fast scanning - so should be no leftovers, Windows FW checked as disabled).
Yet it is working without other conflicts so far, except this one - so i can just connect to the vpn if i temporary disable the comodo firewall (worked with previous FW).

What i do get in FW log: “Windows Operating System - UDP - Client IP (LAN 192.168.) - Port 0 -VPN IP (WAN 109.) - Port 0” I know WOS is a phantom process for, lets say in easy words, “anything else”.
What i did: Create VPN Ports, VPN Zone, Policy for VPN connection, Rule for “All Aplications / Explorer / Global”
VPN-Ports have been set acc. to MS Guide so 0,50,500,1701,4500
VPN-Zone has VPN Server IP Ranges
Policy/Rules - Explorer has extra rules, however to all 3 (see above) i have added:
– Allow UDP Out from Any to VPN-Zone if SourcePort Any and TargetPort group VPN-Ports
– Allow UDP In from VPN-Zone to Any if TargetPort group VPN-Ports and TargetPort Any

That should do it. Also there is no application that interferes with network and doesn’t have the rights to connect (naming - besides default Windows Applications and Comodo - Avast and dnscrypt).

I also tried to deactivate Avast while Comodo was active and connect to VPN.

So what i could think of:

  • I have to add an Application Rule that - for any reason - doesn’t trigger an alert.
  • Comodo and/or Avast and/or Windows and/or dnscrypt interfere in any way.

Sideeffekt probably caused by that (or it’s reason is also the one interfering with the fw):
Whenever i started to connect to a VPN while Comodo FW was active - the connection process or any service etc. somehow remains active in the background and it “1.) wont let me connect to any VPN (while Comodo FW is deactivated for sure) 2.) won’t allow new applications to start (meaning not even accessing CIS Settings/Killswitch/…)” till i restart the pc.

EDIT: Further i recognized that after some time start of applikations (even such small ones like Windows Editor on an SSD 840 pro @ SATA6Gb/s) is heavy delayed - instead of instantly it takes at least 30 sec till 2 min(?). This just happens when i am already connected to the VPN, while Comodo FW has been reactivated. There are no delays if i am completely off-line.