Can't Connect to the Internet


Ever since downloading the firewall a day or so ago I have been unable to connect to the internet.
First, I didn’t realise windows had an active firewall that may have caused some problems. So I uninstalled Comodo although the computer said it was still active after this when I went to check that the windows firewall was now turned off. I re-installed the Comodo firewall but I still can’t connect to the internet - the internet connection normally happens automatically anyway which doesn’t help me figure out how to resolve this. Please help. I urgently need to get online!


Hello, Welcome to the forums

Is there anything in your firewall logs?

Comodo → FireWall → Firewall Events


Was your internet working before you installed comodo? Can you think of anything else that might have interfered with the internet connection?

What mode are you running the firewall in?

Also, do this for me and tell me what you see;
Comodo → Firewall → My Network Zones

I was running it in Safe Mode then tried Training.

The only other thing I installed recently was adaware. But yes, the internet connection failed soon after downloading Comodo.

I also downloaded the file recommended elsewhere on this forum for XP users - WinstockxpFile.exe - but that didn’t fix the prob although it obviously does for some people.

I thought maybe I needed to give the program permission to connect but I don’t know how.

But unfortunately Comodo appears to be the culprit. I did un-install it to see if that restored the connection but as far as my firewall settings were concerned comodo was still active even un-installed. Odd.

I can see LoopBack Zone (new line) IP In [ /]

Alright, Do you have a network zone listed there?

As I’m unsure what your router\modem’s address is we will try this;

Comodo → Fire wall → my network zones → add → A New Network Zone → “Local Area NetWork#1”Now right click on it and select"Add"

IP Address Mask /

and click APPLY

Hope this helps!

I have to go to bed (Time zone difference) If this doesn’t help I will reply within 10 hours if another user doesn’t help you. :slight_smile:

Ok… Firstly, thank you for all your help. This is where I have got to:
The existing network zone was called Loopback Zone. I added the new zone as you said but it had vanished by the time I went back, and yes I did click APPLY.
I went to Stealth Ports and made my new zone trusted. Still no connection.
I deleted the loopback zone and created the new one again.
I restarted the computer… still no connection (it used to connect itself, there is no Click to Connect option)
and the new zone I applied has vanished again and Loopback is back.
I am going to try the CD that came with the router but that didn’t work the first time I set up the connection!


I am SOOO sorry. I have soooo many computers plugged into my hub that I didn’t notice the cable had come out. It connected itself accepting IP In /

Thanks for your help though, I would have despaired if i hadn’t had someone to puzzle it through with.

Lol thats ok :slight_smile: Come back If you have any more questions (:NRD)