Can't connect to the Internet and to the wireless network


I have installed the CIS yesterday. It has worked well so far. However, I am now having the following problem

PROBLEM: Can’t connect to the Internet and to the wireless network, unless I disable the CIS at start-up.I tried re-booting several times, with no success.

Background: I am on Windows XP and my computer connects to the Internet via a D-Link wireless router on my wife’s computer. My adapter switch is a Linksys .
Configuration-wise, the C.I.S. Firewall security level is set to SAFE, MY NETWORK ZONE shows the name and IP adress of my network and I have registered my Linksys app. as TRUSTED. There are NO blocked Network zones. The CIS had worked fine until today.

Symptoms: Occasionally, but not always, the C.I.S. gives me a prompt at start-up that a new network has been detected and I have to assign a new name to it. By the way, why doesn’it ALWAYS detect the network? This might be the problem. Anyway, whenever I get a new Network detection prompt, this new network address has a totally different sequence from my usual IP address. My IP address for my Linksys network is a 192.168.0…sequence, the new one is a 169.254.233…sequence. . I don’t understand. I wouldn’t want to have intruders on my network.( Incidentally, a month back, I found two unknown network names hooked on my network, under My Network Places. They were also showing on the Router configuration and I promptly removed them. Why does the C.I.S. detect a new network, when, in fact, the previous one is listed as well?

I know, the CIS configuration is not among the most user-friendly. It is rather complex, but my original configuration must have been O.K. because it worked. Why the problem now?

I’d appreciate comments on this, because if I keep getting this problem, I’ll have to remove the C.I.S. and try another brand.

Thank you


Can you show for starters your Firewall logs (Firewall → Common Tasks → View firewall events) and Global Rules (Firewall → Advanced → Network Security Policy)?

Do you have other security programs running in the background?

When Windows does not see a network present it will assign your network adapter an IP address in the 169 range. Sometimes that simply happens when it is too busy booting. It can also be indicative of a problem with driver or network hardware. But let’s start with the logs first.