Can't connect to internet with Comodo DNS

I have a broadband connection (not wifi, but one with wire). I connect the internet after logging from ISP site ( Till now I was keeping the IP and DNS numbers blank (auto obtain).

Now when I enter Comodo DNS numbers after connecting the internet, then at that time the internet continues to works, but when I restart laptop next day then I am unable to open ISP or any other site. Once I again keep the DNS numbers blank then I am able to login.

I have ZTE ZXDSL 831 II modem. I tried many IP address (posted on net) to configure it… also the Default Gateway one through IPCONFIG, but I am not able to get any configuration page.

Plz suggest.

i tried the link : blank page
(dns comodo with and without vpn)

and i found this one if it can help you

Thanks Merke for replying.

isitdown shows that the link is not working. But I am able to open the website. Or maybe that website works only those who have internet connection of Reliance?

For information.
It is a site for me doesn’t work. Doesn’t answer. ( Screenshot.)
I use DNS ISP.
It not DNS Comodo problem.
I don’t use DNS Comodo.

[attachment deleted by admin]

i meant that the problem of dns (your post) can be solved more from reliance help than comodo help ; because it is not the first time that a problem of dns in reliance appears (the link explains this).
Fix DNS issue

"I connect the internet after logging from ISP site " so it is a site where anyone can access, right ?
but logging allow you to connect on the net, right ? so someone else cannot, right ? but someone else should have see the page/site ‘reliance’, right ?