Can't connect to internet in Safe Mode

Hi All,

I was using Online Armor, nut am now using Comodo firewall.

I can’t connect to the internet in Safe Mode with Conodo. There was no problem connecting with OA.

Do I need to set it up somehow?

Thanks in advance!

You have an application that does not compatible with firewall when in Safe mode. You have to see what it is!

In safe mode even CIS will not autoload unless separately opened (by double clicking the icon). So, are you able to surf directly without CIS?

Yes, with Online Armor I can use Internet Explorer and Firefox to connect to the web in safe mode.

I it just my computer?
Can everyone else connect to the internet using Comodo?

Indeed, I can’t start CIS is Safe Mode and can’t connect with Safe Mode (with Networking).
At least on my Virtualbox XP.

Is Windows Firewall turned on?

You can try Comodo Dragon browser, its running in Safe Mode by default!

It’s not a browser problem… Comodo Dragon won’t connect in Digibop system in that conditions.

Can you post screenshots of Global Rules (Firewall → Advanced → Network Security Policy) and logs (Firewall → Common Tasks → View Firewall Events)?

Hi Digibop and all

Thanks to all for your posts. Below is my 2 cent input. I experienced the same situation after installing COMODO INTERNET SECURITY (CIS) and spent days trying to address being unable to connect to Internet in safe mode with networking. Internet access was working just fine under normal booting. Various replies to Digibop led me to figure out that CIS was blocking access while I was in safe mode. To overcome this, I took the steps below:

  1. Boot the computer (with Windows XP Pro) in Safe Mode with Networking: To do that you should boot your computer and then when it just starts hit several times on F8. You will then see a window with several options including ‘booting in safe mode’ and ‘in safe mode with networking’. Using the Up Arrow, select the ‘Booting in Safe Mode with Networking’ and let XP complete its booting process. If you have a multi-user computer, select your account and double click on it to enter.
  2. Start CIS (Start up window)
  3. At the Start up window, you see two icons, with one letting you define programs/files that CIS should block and the other letting you define programs/files that CIS should not block.
  4. Click on the latter to allow CIS to define programs/files not to block
  5. In the window, you see a rectangular block where to enter the full path and name of the programs to allow. For a newbie, please use the browse button to help you find your path to the program you want to include. In my case, I wanted to allow IE, Firefox and Safari. To do that I clicked on the browser button, then on:
    a) My computer
    b) C:
    c) C:\Program Files
    d) C:\Program Files\Firefox\Firefox.exe
    Repeat this for all programs you wish CIS not to block.
  6. Close CIS.

Right after closing CIS, you should be able to connect to Internet regardless of the browser.

I hope this helps.



Having the same issue. I am using Windows 7 32-bit. My internet connection is fine in normal mode but Booting from Safe Mode with Networking I can’t get my internet connection to work. Once I unistalled CIS it worked fine in Safe Mode with Networking. Anyone know what steps I need to do to get it working? I installed another Firewall/Security program everything was good. So there’s definitely an issue with CIS. I like the product but I may have to keep it off my machine until this issue is resolved.

What happens when you disable the Comodo Firewall driver in the LAN properties box? See attached image.

[attachment deleted by admin]

Ok I did what you said and it works now in safe mode with networking. I first did what you said in normal mode then the internet went out for 30 seconds then came back up. Then I rebooted my pc into Safe Mode, actually typing the message now using it. Can you tell me why this happens? Is it safe to have the Comodo Firewall Driver not connected? Thanks

Not sure why it happens but I recall it being a solution for a problem a year or so ago where uninstalling Comodo had left behind the driver. That was wreaking havoc…

It was just a long shot to see if it would work. Apparently it did.