Can't connect to Amazon about half the time (and now IMDB.com)

I’ve posted this elsewhere without finding a fix, so maybe time to try here… For the past 11-12 months, I’ve been getting timed out about 50% of the time trying to connect to Amazon, whether I’m going there directly, am moving around within Amazon, or trying to go there from a google search result. The problem occurs with four browsers (Opera 12 and 15+, IE11 and FF31), can happen at any time of day or night, whether or not cache/history are cleared, and whether or not my router is hooked between cable box and desktop computer (Charter cable). All the browsers are excluded in CIS (Malwarebytes doesn’t seem to apply in that regard). When it happens, I’ll switch browsers and usually one of them will connect - or maybe not. If one does, it will go well for anywhere from one link to a few minutes, then I’ll hit a link that won’t load. So I switch back to another browser and maybe it works for a moment or awhile, until it runs into problems. With google searches, Amazon links connect less than 50% of the time. Here are the error messages per browser:

  • “Connection closed by remote server” (Opera 12.17)
  • “The connection was reset” (Firefox)
  • “This page can’t be displayed” (IE11)
  • “The connection was interrputed” (Opera 24 Next)

It was only Amazon up until the past couple of weeks, when IMDB.com started doing something similar. Otherwise, it isn’t happening with any other website, although occasionally I’ll get the same hang with a google search result for some other site. When it started last September, Amazon wrote that they had switched systems and everything wasn’t right yet. A couple of months later, they said I shouldn’t be getting this problem. I’ve reported the problem again recently and it was sent to IT this time. Obviously, were it happening to a lot of people, something would have been done already. But someone else at Windows Secrets forum, where I posted the issue recently, also reported the same problem. At that forum, we ran through a lot of possible network and other tests and fixes, but none solved the problem. The link for that discussion is http://windowssecrets.com/forums/showthread.php/163750-Can-t-connect-to-Amazon-about-50-percent-of-time.

Which leaves CIS to ask about (I also use Malwarebytes Pro, but it started before then). Any ideas? The browsers are excepted. I assume the firewall website exclusion is an exclusion not an exception. Or at least it just seemed to act that way, although with this hit and miss it’s hard to tell for sure. ISP is Charter cable with my desktop, but my Win 7 laptop (wireless) works fine with Amazon. Desktop is Win 8.1 Pro x64, i7-2660K, 16gb RAM and a Sapphire HD7750 GPU. Thanks,

Can you check if you have comodo dns enabled? If so, try disabling it

I recommend using opendns and see if it fixes your problems

I mentioned the Windows Secrets Lounge thread because we’d tried quite a bit there re DNS and IP addresses already.

IPv4 has been set to obtain DNS address automatically, so no Comodo DNS. Flushing dns and then setting the primary and secondary addresses to google’s had no effect. Unchecking IPv6 didn’t either. Nor did taking the router out of the cabling path from modem to computer (the router is for a laptop, not the desktop). I’ll try opendns, but I wouldn’t expect any difference.

Update: opendns didn’t make a difference.

Hi genegold,

  1. You mentioned that you tried to disable IPv6. However, did you try to disable “COMODO Internet Security Firewall Driver” ?
  2. Did you make any changes to TCP/IP parameters in Windows ?
  3. Could you attach your HOSTS file for further inspectation ?
  4. Did you check proxy settings ?

Thanks.

  1. You mentioned that you tried to disable IPv6. However, did you try to disable “COMODO Internet Security Firewall Driver” ?
  • Just did. What effect will that have on the Firewall?
  1. Did you make any changes to TCP/IP parameters in Windows ?
  • only dns IP address that I know of
  1. Could you attach your HOSTS file for further inspectation ?
  • do you mean the hosts file in Windows\system32\drivers\etc? I’ve attached it as a txt file.
  1. Did you check proxy settings ?
  • Yes. Proxy settings in Opera are blank (manual detect is default), unchecked in IE11 and changed to “no proxy” in FF31 from auto-detect, in case that made a difference.

Thanks.

[attachment deleted by admin]

If you disabled the driver and the issue persists then it is most likely not related to the firewall.

Yes.

Sorry, I answered then edited as I found things and attached the hosts file.

After disabling the firewall driver, I rebooted, typed in “amazon.com” and shortly got the “Connection closed by remote server” error.

I posted in the Firewall forum because there is no CIS general one. Could any other part of CIS be causing this?

HOSTS file is fine.
Hmm… I’m not sure. Did you try to disable Website Filtering ?
Even if it’s not related to Firewall, I will try to help you with your issue-- it’s OK.

For now, let’s troubleshoot your problem assuming Firewall is responsible. Please, do the following :
0. Create restore point. [guide]

  1. Run > control appwiz.cpl
  2. Select “COMODO Internet Security Premium” > Click on “Uninstall/Change” > Use uninstaller.
  3. Download this removal tool.
  4. Boot into “Safe Mode”. [guide]
  5. Run the removal tool.
  6. Restart your computer system.
  7. Run > cleanmgr /verylowdisk
  8. Test. Come back with results.

Problems:

  • removal tool has some choices. I chose 1) stop service, then 2) remove from…registry. Said successful.
  • result: no internet connection in Safe Mode with networking or in normal Win 8 mode (read elsewhere that often occurs after CIS uninstall)

So, stopped testing and ran system restore. Comodo is running, but when I click on CIS icon (desktop & sys tray), I get error message, “Error while loading resources…Comodo\Comodo Internet Security \Themes\default.set. Aborting application.” Error box seems to pop up every so often. How do I solve this?

Before running the removal tool, in Safe Mode with Networking, amazon and a google results amazon link loaded with all three browsers but imdb.com wouldn’t. The latter is probably more indicative.

Sorry, I did not understand. You couldn’t access Internet after you ran the removal tool?

If you can’t uninstall CIS, run this tool. Check for leftovers using this tool.

I couldn’t access the internet after running the removal tool in Safe Mode. I rebooted into in Safe Mode with networking and then into normal mode with the same result.

Thinking about it now, the first time in safe mode I ran cleanmgr but forgot to run the removal tool first. So I went back and ran it, but then forgot to run cleanmgr afterward. I’ll need to try it all again. On that second try, the messages I got after running the two options of the removal app - stop the service, then remove…from registry - led me to believe that CIS was uninstalled, but I didn’t actually check elsewhere.

You shouldn’t exaggerate. The main point is to uninstall CIS completely and test.

Exaggerate?

The removal tool is kind of experimental. It is recommended to run it twice (for maximum efficiency).

Well, I ran through the steps again but only ran the removal app once. It didn’t find anything this time, so a second run wouldn’t have been necessary if I’d seen your note.

Result: same amazon and imdb problem with Safe Mode with Networking and Normal mode.

Do I need to reinstall CIS now, since the system restore will have that error box re \Themes\default.set, or is there another way to fix that?

It’s best to install it using normal way. OK-- it is not related to Comodo from what I understand.

Please run cmd (as Administrator) and type the following:
netsh int ip reset c:\resetlog.txt

Attach the produced file here. Thanks.

No file to post:
Resetting, failed
Access is denied
(And yes, I ran as Admin).

Copying over Comodo files from a file backup + a reboot restored everything to normal.

Make sure CIS does not block in some way. Try to disable HIPS & Auto-Sandbox and try again.

Later edit (1),
Go to :
C:\Windows\system32
Right-Click on netsh.exe > Properties > You have to take ownership by going to permission.
After that, try again.

Later edit (2),
If you can’t get it to work, try this tool. This might do the job.

Disabled auto-Sandbox setting and HIPS wasn’t enabled. Ran the MS fixit. I had already taken ownership of everything in C:\Windows, but netsh.exe itself doesn’t show that option in the context menu. Running netsh again, still get reset failure.

I’m going to have to leave this now until later or tomorrow. Many thanks for your ideas.

[1]
That’s strange because I took those from Microsoft documentation. Try to run these with Administrator rights, maybe :

  • netsh winsock reset
  • netsh int ipv4 reset
  • netsh int ipv6 reset

After that, restart your computer system. Test.

[2]
Start Internet Explorer.
On the Tools menu, tap or click Internet options. If you don’t see the Tools menu, press Alt.
In the Internet Options window, tap or click the Advanced tab.
Tap or click Reset. If you’re using Windows Internet Explorer 6, click Restore Default.

After that, restart your computer system. Test (preferably with Internet Explorer).

[3]
Run as administrator the following :
sfc /scannow

[4]
Go to CIS > KillSwitch > “Tools” tab > Select “Quick repair…” > Check if there’s anything wrong.

[5]
Can you access these ?