Cant connect Starcraft to server

I have an issue with Starcraft. I’ve reinstalled it multiple times and added it into the trusted zone of my firewall, but everytime I try to connect to it freezes or stops responding at Accessing Account and takes about 3 minutes to shutdown with taskmanager.

Could someone fill me in on what I should do to allow it to go further?

Battlenet needs to be trusted. I believe its a seperate app. Just put Comodo firewall and D+ in training mode. Delete all entries of Starcraft in firewall and D+. Reboot. Make sure your in training mode for both firewall and D+. I am a gamer and have no issues with any games. TF2 loads trough Steam but also uses another apps called overlay. There are 3 apps just to play TF2. It may be the same for Starcraft. Do what I say and you will be alright. After playing then put the firewall back to train with safe mode and D+ to clean pc mode.

I never had a problem with gaming either, just with this update. But it confuses me since I play Diablo 2 and Warcraft 3 and yet they connect perfectly fine. Just Starcraft will freeze once it hits Accessing Account.

So I think would be accepted already since those 2 games connect fine and my Hellgate London, WoW, and GuildWars connect as well. Everything asked about letting them connect and I made the choices but even doing so for Starcraft it freezes.

alright question, how do I allow that port, do I put it as a privileged port with the single ip and then just click apply. Or is there some other way I’m supposed to allow this port? I just dont want to compromise my security by screwing with a setting that allows someone to enter my pc >_<

LOL, ok I’m sorry. I noticed I had a setting changed on my pc which wouldn’t allow me to modify the firewall so that I could change the Defense+ to Training Mode. But I did what you suggested above and it updated and worked, then I changed it to follow the same rules as the other games and works fine. Thanks again for your help and patience! :BNC