Can't completely uninstall Comodo Firewall

I have really liked using Comodo Firewall Pro 3 x64 the last few months. It has done it’s job well for me. However my overall goal has been, that when finances allow, I would buy a different, hopefuly as equally functional software firewall as Comodo. I run Vista Home Basic x64 by the way.

But I’ve run into some troubles. First I uninstalled Comodo using my Total Uninstaller utility, which does a pretty good job of getting rid of all of the leftovers. After that I even did a manual check for leftover folders and files and I scanned my registry for leftovers using Registry Workshop.

I was very careful to remove only entries that I thought were safe, and yes I do know what I’m doing with the registry. Then I installed Outpost Firewall Pro triall x64, but am even having some problems with that now loading a certain file. I have written Agnitum about that. in the meantime I’m probably will go ahead and uninstall the Outpost until I hear from them.

Also, I just happened to check Device Manager, to see if everything was ok in there. It wasn’t. Under Network Adapters, it shows my onboard VIA Rhine II ethernet installed and working just fine.
But under that are are five references to Comodo Firewall Miniport, each with a yellow exclamation mark on them.

I right-clicked and tried to uninstall them along with the driver, but nothing happened. They’re still there. I even tried disabling them, but they’re already disabled.There seems to be no way to get rid of them! I then went to your forums about removing Comodo and found this page about removing certain Comodo registry entries:;msg119226#msg119226

I had already done that, so all that was left was the legacy keys, and I found them easily. I tried to follow the instructions that’s on the page about changing permissions in Legacy keys, but I obviously did something wrong because I could not delete them. What I did, like the thread says was change permission on each one of them to allow “Full Control” to Everyone.

Then I rebooted, like it said and made sure I was logged in as administrator, which I always am by default. Still I could not delete them.

Ok so now it’s your turn!! How do I fix all of this?

Jan LaFata

[attachment deleted by admin]

Sorry since I was able to exprerience this first-hand I don’t know the exact procedure to fix it but the privilege permissions looks the right answer.
However from what little I know those miniports should be located elsewhere.

The removal instruction topic 1st post refer to comodo drivers listed in Non-UPNP devices (see attached pic).

Did you try to search the registry for Comodo Firewall Miniport?

EDIT: Miniport removal instructions found in;msg192973#msg192973

[attachment deleted by admin]