can't communicate with printer over LAN

I have a LAN with this vista and an xp pc. i can see my printer on the xp but cannot communicate with it .Sharing is ticked but greyed out. The printer uses USB001. Where do i enter that in Comodo?

I can copy my file through the network and go to the xp and print but cannot print from this vista

Thanks if you can help, not even sure it is a firewall problem but have looked everywhere I can think of

Hi david

I don’t have Vista but from what I have read it seems that you need admin rights for everything on that OS. Could it possibly be that you will need to have admin rights in order to access the printer?


I strongly doubt CFP is blocking the printer. It’s not crystal clear in your post as to whether or not the printer is connected to either computer or if it’s just wireless on the LAN - which computer has Comodo in it - or are you talking about one PC with a dual -boot?
This does smack of a problem with the Vista, though.

As from being confused about which machine is which connected to what, I’ll ask this question: does your CFP log have any information about traffic being blocked?

Hi John i do have admin rights. Thanks for your input.


Hi Comofo. Thanks for your reply. The printer is physically connected to the xp machine
and is on wireless netwrok on this vista. It is this vista which has Comodo. No, not dual boot two pc’s

Grue 55 there is no log of traffic being blocked. I had this set up before and it suddenly broke down. I can share files over the LAN with the XP but have to go to xp to print these files. Thanks

I don’t have access to a vista machine, so I’m kind of guessing at things.

The first question is, is the XP attached printer set up to be shared from the XP machine?

The second is, is the printer defined on the vista machine as being a network accessible printer, being accessed by way of the XP machine?

The third is, are the printer drivers installed properly on the vista machine? This usually has the “print test page” function.

Microsoft print sharing uses the typical SMB network ports for name resolution, but uses a different port (I think 9100/tcp) to actually send stuff to the printer. If there’s nothing showing in the log, then it’s either not (yet) a problem, or it isn’t being logged.

I have the same problem.
I had zonealarm installed on the xp pc that has the shared printer connected.
I had zonealarm installed on the vista pc that uses the shared printer to print from (vista - xp printer).
I had to turn off the zonealarm firewall for internet and intranet zones.

As you can imagine this created lots of problems, so I uninstalled zonealarm and now have comodo
on both pc’s, but I can print over the wireless, I am sure it has to do with trusting the printer port or driver or spool ?

Please help.

I had three printers on my network that worked fine from Vista, with a Comodo firewall. After SP1 installed all three stopped working. I had to uninstall all three printers and was able to reinstall two of the three so they would work. I had other problems after SP1, but none were conected to the Comodo firewall. I checked the Microsoft Vista forums and found that other people are having all kinds of problems since SP1 came out. I would have to assume that automatic updates installed SP1 on your machine also and that is where your problem came from. One of my printers was older and a “Vista Driver” was not available, however it worked for 8 months without one, before SP1. The solution that finally solved my probles was to remove Vista and reinstall XP, and that worked really well. Microsoft dose provide free support for problems with a service pack.

Good Luck;