Can't browse local LAN with CIS Firewall on

If someone can help me it would be very much appreciated.

I have VMWare Workstation with a number of VM’s - all in a 192.168.1.x LAN
My main PC is

No VM is able to browse to my main PC via \
I know it is the CIS firewall causing the issue because as soon as I uncheck Enable Firewall all VM’s can browse fine and shares can be accessed.
I have reinstalled CIS and all settings are fresh

There’s nothing in the firewall logs

Everything is on the 192.168.1.x network. Comodo has created the “Home 1” network with this range and allowed access. There’s no firewalls on the VM’s. I’m current forced to turn CIS off every time I access a SMB share.

Please help. Thanks.

See this rules


Thanks for the reply. Didn’t help though. I’ve created a rules for vmnat.exe and allowed full in/out Any MAC Any port any protocol. - both for IP and TCP/UDP but still no change in behaviour.
Also tried both Safe mode and Custom Ruleset - no difference.

I should add that I am attempting to browse by IP i.e. \ not by DNS name so the issue is not DNS.

I can ping though successfully with the firewall on so ICMP is passing OK

Look at one more subject and (rules).;msg591193#msg591193

If there is no help, report:
What OS?
What Comodo FW version?
If it is possible show a screenshot of rules.

More I don’t know, than to help you.

Read the thread but the issue doesn’t get resolved in that thread. Thanks for trying though, it’s actually looking like a bug. It was working going back a month or two so I believe an update has caused the problem

Host running VM Workstation 10.0.2 is Win 7 x64
VM’s are XP SP3, Win 7 x64 and Ubuntu x64 - same issue on all - all in bridged mode

Strangely if I change them to NAT mode they work. The IP they get is 192.168.174.x, and this should be blocked by the firewall as its not in Home #1, but I can browse fine in this state. Go figure.

So it’s all pretty weird - bridged IP’s at 192.168.1.x can’t browse SMB shares yet NAT’s IP’s at 192.168.174.x should be blocked but are able to browse fine.

Firewall is 7.0.317799.4142. I’m not sure how to upload a screenshot to the forum?

Probably it is bug if worked earlier.
You can make the official bug report.

I don’t use new Comodo versions and in detail I don’t know a problem in these versions.
Probably a moderators or other users will be help you.

I'm not sure how to upload a screenshot to the forum?
Screenshot With the best regards.

[attachment deleted by admin]