Can't backup open files

Hi, I am new to Comodo Backup and what I have seen so far highly recommend it. I have been using Cobian for years now which has proved reliabe but the problem is that it hasn’t many of the features Comodo has eg registry and system state backup which is GREAT. I have seen in other posts that some have asked for “wishlist” Volume Shadow Copy service for backing up locked or open files. reading through the replies I see that Comodo does backup open files. Anyway I am putting it to the test and when I use “simple copy” or “synchronize” the open files are not backed up or copied. I don’t get an error message but the files aren’t in the destination folder. It is a bit worrying when backing up to an external drive "file by file’ in simple copy that any files that are open will not be copied or synchronized. There is no problem in Cobian backup as it uses shadow copy. Comodo does backup the open files only if I choose to backup to a .cbu file. The files in question are Quickbooks and Pastel accounting data files. I haven’t tried other open files yet.

Am I missing a setting somewhere? I prefer backing up “file by file” as when the external drive is taken to another premises we only need to copy the files required with explorer and it is also quick to see the files in a folder listing. Once you bring in incremental backup then with the “simple copy” method only the files that have changed whether in use or not will be copied making a lightning fast backup. With cobian backup, incremental and shadow copy selected my backups of fairly large folders are done in milliseconds.

Thanks for a great program - please let me know where I have gone wrong, I don’t want to end up having to use two programs for backing up.

Just a follow up of my previous post. CB definitely cannot backup locked files when in multiuser mode. CB will have to look at incorporating Volume Shadow Copy otherwise it fails. I have done many tests with the full registry backup as well. It does the backup with no problems but :frowning: when you do a clean restore of the registry, it does correctly state the computer needs to be restarted to restore the registry as it is in use, but alas the system then crashes with the restored registry!! and won’t boot up. I think that critical entries in use in the registry are not backed up and thus the computer fails. I made a ghost image of my system partition so I recovered the system quickly after each test. The system state backup failed with error codes (as i see many error codes in other posts) so I gave up. I have to have a reliable backup otherwise there is no point in backing up. I am in the IT business so responsible for my customers backup needs, so have gone back to the free Cobian backup as it does the job, never has error messages and does incremental backups. I now backup the system restore points with Cobian, so that if a virus turns off system restore I can turn it back on, recover the backed up restore points and then do a system restore to get the system back up to a clean state.

By the way I did many tests, using “virus techniques” to disable many things in the registry by REG commandline in batch files and none of the registry backups worked with Comodo Backup or Genie backup (they only restore the existing registry entries and won’t remove the added entries that are introduced into the registry that can play havoc with a system. I disabled task manager, regedit, system restore, folder options so hidden files cannot be ticked, disabled run command, put the computer in a loop to taskkill programs like iexplore firefox word etc etc - no task manager so the system is just about useless!
This is when a registry restore is needed and none of the backup programs tested worked!! >:(

So it looks that the only solution at present would be system restore with backed up restore points. Of course I do have a clone image of my system partition that only has the system and programs and all my data is safe on another partition… so in about 10 mins I have a clean system up and running…

Will look at CB again when shadow copy and incremental copy is introduced… (as I mentioned before with Cobian and incremental - straight backup to an external drive takes 10mins max - often when very little changes less than a minute.)

Here is a copy of my latest Log file in Cobian (the data backed up is 10Gb):
2010-07-15 21:10 Deleting the Volume Shadow Copy snapshot “a4a4f65d-edf5-45d8-ba2c-99becdd14546”
2010-07-15 21:10 The Volume Shadow Copy snapshot set has been successfully deleted
2010-07-15 21:10 ** The backup of “Thursday All 9pm” has ended. Elapsed time for the task: 0 hour(s), 10 minute(s), 22 second(s) **
2010-07-15 21:10 The system can now enter Sleep mode
2010-07-15 21:10 Total elapsed time for all the backed up tasks: Hours: 0, Minutes: 10, Seconds: 26
2010-07-15 21:10 *** Backup finished. Processed files: 31038. Backed up files: 1876. Errors: 0 ***

Just my latest views - maybe of help to someone out there. :wink:


Synchronized copy and simple copy have some issues.
They cannot backup locked files, only .cbu file format can.
We will fix this in the next release.
Also incrementals and VSS support will be available in the next release.
As for registry backup, did you try entire registry or custom registry?


Hi Emanuel,

Thats great news about the next release!

For registry backup I backed up the entire registry to a .cbu file. There were no errors. I then restored the backup but the system wouldn’t get into windows. XP went as far as the welcome screen and then stopped and wouldn’t continue from that point. I then had to restore my image to get back into the system. I tried three times but the results were the same. I wonder if some driverl registry keys are locked so were not included in the backup, causing the problem. Maybe the VSS support will solve the issue?


I know I’ll get off topic.
But for registry backup/restore, I never find a better option than the old and good ERUNT.

Thanks for that Tech!

Downloaded and tested ERUNT and works like a dream! This is an excellent option and no errors!

Thanks again! :slight_smile:

You’re welcome dowlingf.
It works if you boot from USB or DOS also.