can't arrange desktop icon manually [RESOLVED]

hi all (:WAV)
got new problem
i have 27 desktop icons (CAV,CFP,My computer,and so on). on desktop right click option, i had unchecked the “auto arrange” option (arrange icon by) so i can arrange them manually.
today, after my computer hibernated, i found the icons are automatically align on the left side, i’ve tried to arrange them again,but after restarting computer or clicking “refresh” on right click option, the icons are arranged on the left side again. never got this problem before.
no serious problem, but this is (:AGY). so somebody help me pls, maybe my computer’s haunted.


Try this:

I have not tried it so no guarantees, it is just something I came across.


EDIT: Before you try the above make sure you have Unchecked: Lock Web Items on Desktop. If this is ticked then items can be moved but they will rearrange themselves after restart or refresh.


WOW that’s fast. ;D
ths, opened the link, it says: Icon Restore is the perfect solution for people that have to change the screen resolution often.

maybe i accidentally clicked on screen resolution option. i’ll check it out. thx a lot N.T.T.W


Before you try it right click your desktop and make sure Lock Web Items on Desktop is unticked. This may solve it without downloading anything.


i’ve checked (examinate) it. it’s unchecked. i’m downloading the icon restore now, dial up connection here, :THNK.

thx N.T.TW

the icon restore help me to arrange my desktop. :■■■■
but, now i have to click “restore desktop icon layout” all the time. :THNK
that’s weird, i’ve never had this problem before, is there something wrong with my setting?

This may be worth reading:


wooooooo, i really don’t wanna play /mess anything in my registry. maybe i’ve done something wrong with my registry cleaning bad. (:AGY)

Try downloading Tweak UI:

Once installed, under Explorer, then customizations there is an option to increase the ‘folders to remember’ setting. Worth a try and easily reversed using the same method.


done that, i increased it to 1000. but maybe i’ve done it wrong? after restart, the “folders to remember” setting back to 400. i’ll try it again.

okay, i’ve done it right this time. but still no use. my desktop icons still messed up. any other suggestion? even the “icon restore” can’t really restore the icon, some icons still misplaced after restoring.

There are usually two causes of this problem, as far as I can tell:

Are you using Remote Desktop? (Right click ‘My Computer’ click ‘properties’ and ‘remote’. If this is ticked to ‘allow users to connect remotely to this computer’ this may be the source of your problem.

The other cause is when explorer.exe is not shutting down correctly. Not sure how to fix this but it seems to be a common problem. Might be worth looking in your event viewer (Start/Run type eventvwr.msc and press enter) to see if there are any entries indicating problems with explorer.exe.


Make sure it’s not locked. If it’s not this then post a screenshot so that we can see what it looks like.

[attachment deleted by admin]

maybe you need to “ghost” it ;D

Disable the Desktop Cleaning Wizard (I got this idea from spotting your pic on the “Unused Desto…” icon.

Since you fear the registry as much as you fear ghosts, check the Group Policy (Start > Run > gpedit.msc). See my pic - some relevant options in there. ()Hint Hint().

[attachment deleted by admin]

:THNK li’l help for miserable man pls (:SAD)

I can’t be 100% certain that RegSeeker is the actual culprit since I’ve deleted just about everything whenever it detects something (stupid o me) and have not experienced your issue. Not certain because everyone’s computer settings are different…But why not just restore those deleted things in the program’s backup to confirm your theory? You may have to restart the computer afterwards.

Have you checked out the other options in the Group Policy? If all of them are ‘Not Configured’, then leave them as they are in their default states. I just thought you might’ve changed them or something. The example of my previous screenshot actually should be “enabled”, but again, you don’t have to change it from ‘Not Configured’ to be safe.

they’re all not configured, , ok, i’ll try to restore regseeker backup. thx soya

(:SAD) restoring regseeker backup didn’t work. i’ll wait for a couple days to see if somebody has another solution. then i’ll just reinstall my OS (oh my…)

Still think this may be due to some problem with explorer.exe:

before you decide to re-install Operating system it may be worth trying the scandisc (Check disc for errors).
Right click C Drive, properties, tools then error checking. Tick both boxes and let pc re-boot.
The scan can take ages but it does fix the odd problem here and there.


gee, thx NTTW. much appreciated!!! i’ll do it
i’m really depressed only to think about re-installing OS, AV,Firewall, creating trusted zone.
i’ll try everything.