Can't access Internet in W7 x64 corporate PC

I’ve installed latest CIS in a Windows 7 x64 and since then, I can’t access to Internet.
It’s a strange behaviour because I can search through Google but whenever I try to follow the links, there is no success. The same occurs if I type the link directly.
I’ve disabled previously Windows’s firewall, and the only way to access Internet is dissabling CIS’s Firewall.
The same problem occurs when upgrading the virus signature of CIS. It doesn’t work unless I disable the firewall.
I noticed that CIS detected my Internet connection but there is no popup when a program tries to connect to Internet.

I don’t have any problem using the same CIS version in a Windows XP SP3. What could be the cause of this issue?


Maybe the instalation is corrupted, try to reinstall CIS

I’ll tried it several times with the same result.
I’ve installed as an admin with no succes.
Tomorrow I’ll try once again even the x86 version.

Isn’t it a problem with DNS?
After uninstalling CIS, can you access internet?

I don’t need to uninstall CIS in order to access to Internet. The problem is solved if I disable CIS’s firewall.
Anyway I’ll try to change my DNS -using Comodo DNS for example-

Did you try Diagnostics on the More tab? Check your Global Rules and make sure there isn’t a block rule.

I performed Diagnostics and CIS is ok.
I’ve checked global rules and there is only the Comodo’s default ones.
I even tried with another DNS and it doesn’t work

Can you show screenshots of the firewall logs (View Firewall Events) and your Global Rules (Network Security Policy)?

Also tell us what rule is made for svchost.exe.Break it down following this format:

Source Address:
Destination Address:
Source Port:
Destination Port:

Besides the information requested I have to point that this computer it

[attachment deleted by admin]

I am not seeing anything out of the ordinary.

May be there are left overs from previous security programs. Try running removal tools of those programs or try the following tutorial.

We are gonna take a look to see if there are some old drivers of your previously uninstalled security programs are still around. Go to Device Manager → View → show hidden devices → now look under Non Plug and Play drivers → when you see a driver that belongs to your previous security programs click right → uninstall —> reboot your computer.

When the problem persists make sure there are no auto starts from your previous security programs. Download Autoruns and run it.

This program finds about all auto starts in Windows. This tool can therefore seriously damage Windows when not handled properly. After starting push Escape and go to Options and choose to hide Windows and Microsoft entries, to include empty locations and then push F5 to refresh.

Now check all entries to see if there are references to your previous security program. When you find them untick them. After unticking reboot your computer and see what happens.

Thanks Eric but CIS is installed in a new fresh W7 x64 and no other security suits have been installed before.
In fact, CIS was the first application that I installed in the computer. Anyway I’ll run Autoruns when come back to the office.

I’m still thinking there is some problem with DNS. Messenger can connect without any problem and I can search using Google but I can’t access to any web site and even CIS is unable to download updates when firewall is enabled.
What is strange for me is that firewall never -or almost never- alert me about incoming/outgoing traffic. In my XP I’m used to see this alerts whenever a new application tries to access to Internet.

I have another W7 x64 in my home so I’ll uninstall Avira and install CIS to try it out.

Well, this morning I’ve installed CIS in my home’s computer with the same W7 x64 and I haven’t experienced any problem so far.
When I’ll come back to my office I’ll try to install CIS in another computer with XP SP3 to see what happens. If it’s a DNS issue I guess I’ll get the same problem.

I’ve realized that one of my post is incompleted. I don’t know what happened but I in the post where I uploaded the images requested, I explained that the office computer is part from a corporate intranet and DNS point to the servers -2-. I’ve added Comodo’s DNS but the problem still remains.
I also noticed that the first time I set up my Internet settings I was wrong to write the default Gateway.
I don’t know if this could cause the problem but I’ll unistall CIS completely and try to reinstall with the new settings.

Finally I’ve found the cause of the issue!!!

I’ve tried to install CIS in a different company’s computer with Windows XP SP3 x86 and the same happened: I’m unable to access Internet whenever Comodo’s firewall is active.
Because I’m not facing this problem in my home’s computer I guessed it’s a DNS problem but ther wasn’t because I changed it with Comodo’s ones and everything keeps the same.

‘Playing’ with firewall settings y realized that the problem disappeared if I switched off “Block fragmented IP”.
That’s it. With this setting off, I can surf the web again.
I’ve tried this workaround in both, W7 x64 and XP x86, and works fine.

I apologize for my poor english