Can't Access Internet - Fresh Install v6.0 on Win7 Pro SP1 [M181]1[v6]


  1. What you did:
  • Installed Win7 Pro 32 Bit
  • Reboot
  • Updated Win7
  • Installed CIS v6. Antivirus and Firewall. No Dragon or Geekbuddy. No Comodo DNS. Default installation directory. Was not able to update virus database due to “No Connection Activity”.
  • Uninstalled v6. At this point internet connection started working again.
  • Rebooted
    Using Win 7 Professional x32 SP1
  1. What actually happened or you actually saw: See 1.
  2. What you expected to happen or see: I expected everything to work as normal. I did the same on Win Xp Pro x32 SP3 and on that computer everything works fine.
  3. How you tried to fix it & what happened:
  • If I open Local Area Connection Properties and uncheck COMODO Internet Security Firewall Driver the connection returns.
  1. If a software compatibility problem have U tried the compatibility fixes (link in format)?: No
  2. Details & exact version of any software (execpt CIS) involved (with download link unless malware): n/a
  3. Whether you can make the problem happen again, and if so precise steps to make it happen: Yes.
  • Re-enable COMODO Internet Security Firewall Driver.
  1. Any other information (eg your guess regarding the cause, with reasons): My guess:
    Something with the kernel drivers on Win 7 that are different on Xp?

B. FILES APPENDED. (Please zip unless screenshots).
0. A diagnostics report file (Click ‘?’ in top right of main GUI) Required for all issues): Appended

  1. Killswitch csv file (see Advanced tasks ~ Watch Activity) or 5.x Active Process List. If accessible, required for all issues: Included csv file.
  2. Screenshots illustrating the bug: Not Appended
  3. Screenshots of related CIS event logs: Not Appended
  4. A CIS config report or file: Settings images attached.
  5. Crash or freeze dump file: Not appended
  6. Screenshot of More~About page. Can be used instead of typed product and AV database version: Not appended. CIS 6.0.260739.2674 DB: 14698


  1. CIS version, AV database version & configuration: CIS 6.0.260739.2674 DB: 14698
    Tried default and also my config. See A4.
  2. a) Have you updated (without uninstall) from a previous version of CIS: No.
    b) If so, have you tried a clean reinstall (without losing settings - if not please do)?: n/a
  3. a) Have you imported a config from a previous version of CIS: No and Yes, both. Same results.
    b) If so, have U tried a standard config (without losing settings - if not please do)?: Yes.
  4. Have you made any other major changes to the default config? (eg ticked ‘block all unknown requests’, other egs here.): No and Yes, both.
  5. Defense+, Sandbox, Firewall & AV security levels: See A4.
  6. OS version, service pack, number of bits, UAC setting, & account type: Windows 7 Pro, SP1, 32bit, disabled, Admin. Fully Updated.
  7. Other security and utility software currently installed: None.
  8. Other security software previously installed at any time since Windows was last installed*: None.
  9. Virtual machine used (Please do NOT use Virtual box):[color=blue] None.

[attachment deleted by admin]

Many thanks for your report, L.A.R.

Just to check, not a problem. Did you copy DNS’s report as some of the text is the same. (No problem if you did copy it, but I would need to know if both reports are from you :slight_smile: )

Best wishes


Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again


Thanks mouse1,

For now I’m back to v5.12.256249.2599 (which seems to be working OK). Something to note: Changing to Comodo Secure DNS with either v6.0 or v5.12 also disables my Internet connection. I have to have my DNS set to “Obtain One Automatically”.

Nope, L.A.R. isn’t me ; ).

But good to know that I’m not the only one with the same problem.

It’s strange I am set to same, and have 5 DNS servers on my router inc Comodo (on failover)

Where are you changing this? (Internet options?, Individual browser? CIS installer?)

Are you using IPv6, as there have been wierd problems with IPv6

I’m well back to nothing ATM CIS 6.0 won.t start. CMD agent is frozen and even a system restore does not help.

Best wishes


When you have the main bug, are web sites saying ‘not found’, and can you ping?

IPv4. I tried from the installer and setting the addresses manually. Both blocked the Net.

Browsers say “not found” and the systray icon shows yellow “No Internet Access”.

For what it’s worth, some ISPs prevent the use ot third-party DNS providers. Have you tried using a different provider, other the Comodo, to discount this possibility?

With regard to your settings, you might want to consider (for testing purposes only, if you feel you need these) unchecking the boxes for:

Block Fragmented IP Traffic
Do Protocol Analysis
Enable Anti-ARP Spoofing

Likewise, if you’re not using IPv6, there’s no need to filter IPv6 traffic.

Unfortunately, there doesn’t seem to be any information on Your Application firewall rules and you appear to be using your own configuration file. Perhaps it’s worth posting both…

Wouldn’t disabling the firewall be effective? I tried that, but the problem persisted. I also tried a default install without touching any settings. As soon as CIS was installed, the Net connection was lost.

It should be but it depends how the firewall was disabled. If you’re referring to disabling the driver, then it should be enough, although I’d still expect other system/comodo component interaction.

I also tried a default install without touching any settings. As soon as CIS was installed, the Net connection was lost.

Fair enough, I didn’t see that part. Out of interest, have you tried with a firewall only installation?

No, not yet, I’m still in the middle of setting up Win7. If I disable the Comodo Firewall Kernel Driver under IPv4 properties the connection returns.

CIS 6.0.264710.2708

Same exact problem reported here:;msg646870#msg646870

If the Comodo Firewall Driver is disabled, the Internet connection returns. If it’s re-enabled, the connection is lost.

What a shame. I waited 4 years to get a “timer” and now I can’t use the new version! :-[

[attachment deleted by admin]

Have you tried another network card or looked for an update network card driver?
Just a thought…

Just a stab in the dark.
I do not suppose an old FW driver is being left behind, causing two drivers trying to be active and conflicting with each other.
Check to be sure only one is present in Widows Device Manager.
See Eric’s post here.

Just for more info - how did you install 2708? Clean install, uninstall 2674 → then installed 2708, ‘updated’ 2674 to 2708 via downloaded installer package or through 2674’s check for updates (internal program)?

I have HDD trays for swapping operating systems. The program works on WinXP and blocks the connection on Win7. Both drives are mounted in the same machine. Same Ethernet card. Same drivers (which are up-to-date). Note that 5.12 works fine with Win7 and my current Ethernet card.

On my first try, it was a fresh install of Win7 and a fresh install of CIS 6.0 (no left over drivers). On this next clean install, I made sure the drivers were uninstalled before installing this new version.

Totally uninstalled 5.12 with Revo. Deleted all left over directories. Made sure the drivers were uninstalled. Did a clean install from cispremium_installer.exe. As soon as CIS is installed, the Internet connection is lost. Disabling the Comodo Firewall Driver returns the connection.

Out of interest, is there any connectivity or is it just the Internet. Are there any alerts of any kind post installation of CIS. Also are there any errors in the Windows System log?

I had something similar to this earlier today, when putting the new version on a test box. Basically, after installation and reboot, I had no connectivity at all. What I had to do, three times, is disable and re-enable the network adapter. Finally, after about 5 minutes it connected. It’s not the first time I’ve seen this but this was the longest it’s taken to become active.

Thanks for the update. Just to see further, is there any ‘caution’ (yellow triangle) items in the Device Manager when Comodo Firewall Driver is active? (You may have to reboot with the firewall driver active to see what is conflicting.)