Can't access comodo menu after clicking icon in upper left corner

I have had this browser installed for quite some time and use it as my default browser but just lately it started acting up. When I click the comodo icon nothing happens so I can’t access the internal menu to change any settings. Tried uninstall and re install but doesn’t help. Any ideas ?


What operating system are you running. Also, is the Comodo Dragon window maximized when you attempt to click the menu button? Are you using any custom toolbar/taskbar?

Thank you.

Running windows 7 home prem 64 bit and no custom taskbar or toolbar at all. If I right click on the url bar I can access setting by clicking on “edit search engine” and I can get in around from there but clicking on the icon does absolutely nothing anymore.

Hi wildwhitetiger,
I am not sure why this is happening unless something is conflicting or gone astray with your Dragon user profile.
Try with all 3rd party themes and extensions disabled.

Until this is resolved will the keyboard shortcut Alt+F open it for you?

Thanks for the quick replies. Alt + F does nothing have uninstalled and cleared out profile and then tried to clean out any remaining remnants of dragon and reinstalled and is still doing it. I have no other extension installed right now.

Sorry I have no answers for you, I don’t recall ever seeing this happen before.

When you say cleared out your profile, did you delete the entire Dragon User Profile?
To create a new user profile in Comodo Dragon
Note: Export bookmarks for safe keeping before entirely deleting your profile.

Have you tried the portable version to see if the issue still remains?
This is totally independent from your installed version.
Portable Version

Kind regards.

I’m having the same problem, however I can access using alt F.

Hi and welcome BossHogg,
When did this issue start occurring?
Is this issue occurring with the default theme?


Thanks for the welcome, it started about 3 or 4 weeks ago. Using the default theme, running W7 ultimate 32 bit.

Hi BossHogg,
I thought the issue may have started with the release of V31.1, but this was only about 2 weeks ago.
Considering the time that this started occurring is an estimate, I am wondering if this started occurring for you when Dragon updated to V31.1.
Considering this possibility, I will have contacted Staff to see if they have time to revisit this topic.

Have you tried the portable version to see if the issue still remains?
This would help decide if it is an issue with the installed version or possible the installed versions user profile.
This is totally independent from your installed version.
Portable Version



I’ve tested out scenarios with various resolutions and DPI settings with no success in reproducing the issue. Dragon’s interface was responsive in all cases. I’ll need your help in troubleshooting this issue and discovering the source.
You can help by answering to some questions:

  • Does the menu button react when when you hover it with the mouse (it should display a red ring around it when the cursor is over it)?
  • What screen resolution are you using and does the behavior change when you change the screen resolution?
  • What DPI settings do you use and does the behavior change when you change the DPI settings?
  • What theme do you have applied for your desktop (Windows 7 aero, Windows 7 basic, Windows classic)?
  • Are you running Dragon in a sandbox?
  • Do other windows react when you click in the same area where Dragon’s menu button is located?(You can check this by maximizing the window and right clicking the location. This should open a context menu for the running application).
  • Does Dragon’s title bar react to the mouse click? (Normally you can click the title bar and drag the window).

Thank you.

I’ll try and answer your questions next time I fire my PC up. I’m posting on my phone at the moment.