Can't access CFP's included help file using Internet Explorer

When clicking on “? What do these settings do?” It pops up the HTML Help window but then I get the message below.

Internet Explorer cannot download.

Internet Explorer was not able to open this internet site. The requested site is either unavailable or cannot be found. Please try again later.

If I navigate into Comodo’s folder and find cfp.chm (the included html help file) I can open it (using Microsoft Help Executable) and run through the help topics without any problem. The problem arises when I try to launch Help through the user interface of Comodo Firewall Pro 3.0.130268 that I experience the problem. When I try to use IE to open cfp.chm I get a pop-up window “File Download - Security Warning” warning about downloading the file and then IE crashes.

Running WindowsXP Pro SP2, Internet Explorer 7 (7.0.5730.13) have all service patches/updates installed.

Event Type: Error Event Source: Application Error Event Category: None Event ID: 1000 Date: 11/30/2007 Time: 4:39:46 PM User: N/A Computer: STARFLEET Description: Faulting application iexplore.exe, version 7.0.6000.16544, faulting module unknown, version 0.0.0.0, fault address 0x022e3bab.

For more information, see Help and Support Center at hxxp://go.microsoft.com/fwlink/events.asp.
Data:
0000: 41 70 70 6c 69 63 61 74 Applicat
0008: 69 6f 6e 20 46 61 69 6c ion Fail
0010: 75 72 65 20 20 69 65 78 ure iex
0018: 70 6c 6f 72 65 2e 65 78 plore.ex
0020: 65 20 37 2e 30 2e 36 30 e 7.0.60
0028: 30 30 2e 31 36 35 34 34 00.16544
0030: 20 69 6e 20 75 6e 6b 6e in unkn
0038: 6f 77 6e 20 30 2e 30 2e own 0.0.
0040: 30 2e 30 20 61 74 20 6f 0.0 at o
0048: 66 66 73 65 74 20 30 32 ffset 02
0050: 32 65 33 62 61 62 0d 0a 2e3bab…

The ‘support’ link opens “Help and Support Center” which doesn’t give much info.

Details Product: Windows Operating System ID: 1000 Source: Application Error Version: 5.2 Symbolic Name: ER_USERCRASH_LOG Message: Faulting application %1, version %2, faulting module %3, version %4, fault address 0x%5.

Explanation
The indicated program stopped unexpectedly. The message contains details on which program and module stopped. A matching event with Event ID 1001 might also appear in the event log. This matching event displays information about the specific error that occurred.

In Internet Options (Advanced tab) I changed the settings to “Allow active content from CDs to run on My Computer” and “Allow active content to run in files on My Computer”. Still doesn’t help, IE crashes the minute the help file tries to open. (:AGY)

TIA,
Izzy

Hi Izzzatso

Welcome to Comodo forums

This is a known problem and will hopefully be fixed in the next patch that will be coming out.

John

Thanks for the reply.

I was over at a friend’s today and checked on his system. He has the same OS, version of IE and same version of Comodo. He doesn’t have the problem, the help file opens like it’s supposed to.

For the time being, I put a shortcut on my desktop to the help file.

I have a very similar problem, but with a potentially significant difference; the “faulting” application is cfp.exe, and not IE (or at least that’s what it appears to be). When I click on the “what do these settings do” link the screen draws a blank window, but then a few seconds later I get a message basically saying that Comodo has crashed. When I dispatch that window the entire Comodo GUI disappears, and the icon in the system tray vanishes as well. The Application Event log posts this message:

Faulting application cfp.exe, version 1.0.0.1, faulting module , version 0.0.0.0, fault address 0x00000000

I also get a 0 byte .dmp file in %temp% when this occurs, and it happens every single time I click on that “settings” link.

I running XP SP2, which is fully patched, and CPF 3.0.13.268. My AV program is Symantec 8.1.

Hi JimWilson

Go to the following link and try the new Beta version, I believe it will help with your problem. Be sure to uninstall your present version first (I like to uninstall in safe mode). Also do not allow your beta version to update or it will really down grade to the old version.

Let us know how it works for you.

John

[url=https://forums.comodo.com/cfp_beta_corner/special_test_edition_for_the_users_who_had_problems_with_cfp_013268-t16824.0.htm]https://forums.comodo.com/cfp_beta_corner/special_test_edition_for_the_users_who_had_problems_with_cfp_3013268-t16824.0.html[/url]

John;

thanks, I’ll give that version a try. I’ve got two questions though (well, 1 question and 1 observation)…

Question: I just tried the Export feature for the first time. Will that save all of my configuration information, so I’ll just need to Import that into the new version and it will be configured in the identical manner? Or are there some settings I’ll have to redo by hand?

Observation: the link you posted gives a 404 error because the “l” at the very end of the link (in .html) isn’t part of the clickable link, so I’m just reposting it with the “l” included:

https://forums.comodo.com/cfp_beta_corner/special_test_edition_for_the_users_who_had_problems_with_cfp_3013268-t16824.0.html

Thanks Jim

Since I posted there is a new version released. I will try to get the link right this time.

John

https://forums.comodo.com/feedbackcommentsannouncementsnews/comodo_firewall_pro_3014276_has_been_released-t17010.0.html

I just downloaded that version, and your link worked just fine… :BNC

In my case I think it was a bad install. I uninstalled, cleaned out the registry, dumped the contents of the prefetch folder then redownloaded and installed fresh. Problem solved for me.