Cannot update virus database behind proxy [RESOLVED]

Computer joined to domain. Able to update CIS under Miscellaneous but cannot update virus database.

Reason: Virus database update does not use proxy settings (tries direct connection) whereas CIS update uses browser proxy settings.

  1. 32-bit
  2. Vista SP1
  3. BOClean 4.27, Windows Defender and SafeSurf
  4. Unable to update virus database when using a proxy
  5. Set browser settings to :8080 and tried configuration file (proxy.js).
  6. Defense+ = Clean PC Mode. Firewall = Safe Mode
  7. n/a
  8. Administrator account. UAC disabled.


So you cannot get updates through a proxy… that it pretty lame!
So Comodo designed these marvellous tools (AV, firewall and Internet security) but millions of us are unable to update it because they did no t include two silly boxes for the proxy and the port.

Sorry to say that I will have to uninstall Comodo from my two PCs and no recommend it to tens of other people. That is a petty.

Hi edelrc

CIS is able to update fine as it uses the browser’s proxy settings to connect. However, I am stuck with the original virus signature as it tries to make a direct connection instead (ignoring any proxy settings). Not a real problem as I’m relying mosting on Defense+ but still, it shouldn’t be too hard to fix. Hopefully it will get fixed in an upcoming update.


Yep I have the same problem when I installed CIS at work. CIS update OK, AV signature not. Proxy, of course.

+1 for me Vista, Sp1 Enterprise x32.

Good news :-TU. I read a reply from Melih somewhere (I can’t find it now) saying that this was going to be fixed in the next update.


Hello everybody!

I have this same problem:

  1. Dell Latitutde D630 with an Intel Core 2 Duo
  2. Windows XP SP2 (32 bit)
  3. CIS 3.5.54375.427, Comodo BOClean and Checkpoint SecureClient
  4. Installed CIS at the office behind a proxy server. Antivirus and CIS updates worked perfectly. But when I’m at home I disable the proxy server in Internet Explorer to access the Internet. In this situation I cannot update the antivirus but checking for CIS updates apparently works.
  5. Antivirus updates work when I’m at the office behind the proxy or when I connect to the VPN using Secureclient (in this situation Internet connections work through the proxy server)
    6.Defense+ and Firewall+ mode: both are in safe mode.
    8.I’m using an Administrator account.

Hope this problem is solved soon. I replaced ZoneAlarm 8 with CIS, and CIS is faster when booting or closing Windows and, except for this bug, seems as good or even better than ZoneAlarm. Congratulations Comodo!! (:CLP)

I would sure like to know when that update is expected to be released. I am a bit nervous running for too long with old virus definitions… :-\

It’s fixed ;D. Just update with CIS.


Really? When trying to update, CIS says: “Updates are available. Please click on ‘Next’ button to start the update process’”. Following this, after clicking on ‘Next’ we see the message: “Error 113 … Seems Internet connection lost halfway during update download…” Of course, this is a progress, but…

It looks like CIS update works after replacing predefined policy for “Comodo Internet Security” from “Outgoing only” to “Trusted application”.

You need to get the build 432 for everything to work right, this can happen. :slight_smile: Export your configuration & do a reinstall and import your original settings.


Thanks for the info. Is the build you mentioned available for download? It looks like the download link on Comodo site isn’t updated yet.

Et voila: .

Still have this problem.
Is there any solution?
I use CIS 3.5.57173.439

I also keep getting this Error 113 and there is nothing wrong with my internet connection.
I am currently running CIS version 3.5.57173.439 on Windows Vista Home Premium 64-bit.
Is there a solution to getting the updater to work properly?

Version 3.8.x support full proxy and authentication, please upgrade to the latest version.

I still believe there is a problem even with the latest build. Builds prior to this did work (most of the time). Since the proxy section was added, I haven’t been able to update my virus DB yet :(. I’ve posted this issue in another thread but if someone could confirm that this does work, then I can then look for problems my end.


I’m at 986 at the moment.
There was also a post from umesh about not having the update servers available, because of infra updates, from the top of my head that was yesterday…

Just checked and the latest DB is still 986. Just be patient I guess…